summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2016-06-27 11:25:34 -0700
committerNikolaus Rath <Nikolaus@rath.org>2019-10-20 12:01:04 +0100
commit7767333d725f7ab036363e3d2e8f0fa2318ef2ff (patch)
treeb52c956f079b29decd91582ce51c09f362a46b08
parent1969e572b94d8bf91970ce5192639757b68bdb87 (diff)
Don't hide pdflatex output.
Origin: debian Forwarded: not-needed Patch-Name: show_pdflatex_output.diff Upstream is not interested in this patch. Gbp-Pq: Name show_pdflatex_output.diff
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 02964e1..ee7a257 100755
--- a/setup.py
+++ b/setup.py
@@ -99,9 +99,8 @@ class build_docs(setuptools.Command):
print('Running pdflatex...')
for _ in range(3):
- with open('/dev/null', 'wb') as null:
- subprocess.check_call(['pdflatex', '-interaction', 'batchmode', 'manual.tex'],
- cwd=os.path.join(dest_dir, 'latex'), stdout=null)
+ subprocess.check_call(['pdflatex', '-interaction', 'nonstopmode', 'manual.tex'],
+ cwd=os.path.join(dest_dir, 'latex'))
os.rename(os.path.join(dest_dir, 'latex', 'manual.pdf'),
os.path.join(dest_dir, 'manual.pdf'))