summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2016-03-09 10:08:21 -0800
committerNikolaus Rath <Nikolaus@rath.org>2016-03-09 10:08:21 -0800
commit5b62499deb280253671a3c468644335be9e55f04 (patch)
tree96a12cd0c8833ca23e5993614b7d0405f2422a9f /bin
Import s3ql_1.0.1.orig.tar.bz2
Diffstat (limited to 'bin')
-rwxr-xr-xbin/fsck.s3ql23
-rwxr-xr-xbin/mkfs.s3ql23
-rwxr-xr-xbin/mount.s3ql23
-rwxr-xr-xbin/s3qladm23
-rwxr-xr-xbin/s3qlcp23
-rwxr-xr-xbin/s3qlctrl23
-rwxr-xr-xbin/s3qllock23
-rwxr-xr-xbin/s3qlrm23
-rwxr-xr-xbin/s3qlstat23
-rwxr-xr-xbin/umount.s3ql23
10 files changed, 230 insertions, 0 deletions
diff --git a/bin/fsck.s3ql b/bin/fsck.s3ql
new file mode 100755
index 0000000..ddc4fb6
--- /dev/null
+++ b/bin/fsck.s3ql
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+fsck.s3ql - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) 2008-2009 Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.fsck
+s3ql.cli.fsck.main(sys.argv[1:]) \ No newline at end of file
diff --git a/bin/mkfs.s3ql b/bin/mkfs.s3ql
new file mode 100755
index 0000000..ed85b95
--- /dev/null
+++ b/bin/mkfs.s3ql
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+mkfs.s3ql - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) 2008-2009 Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.mkfs
+s3ql.cli.mkfs.main(sys.argv[1:]) \ No newline at end of file
diff --git a/bin/mount.s3ql b/bin/mount.s3ql
new file mode 100755
index 0000000..f292af6
--- /dev/null
+++ b/bin/mount.s3ql
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+mount.s3ql - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) 2008-2009 Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.mount
+s3ql.cli.mount.main(sys.argv[1:]) \ No newline at end of file
diff --git a/bin/s3qladm b/bin/s3qladm
new file mode 100755
index 0000000..a877af2
--- /dev/null
+++ b/bin/s3qladm
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+s3qladm - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) 2008-2010 Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.adm
+s3ql.cli.adm.main(sys.argv[1:])
diff --git a/bin/s3qlcp b/bin/s3qlcp
new file mode 100755
index 0000000..2dc560b
--- /dev/null
+++ b/bin/s3qlcp
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+s3qlcp - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) 2008-2009 Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.cp
+s3ql.cli.cp.main(sys.argv[1:])
diff --git a/bin/s3qlctrl b/bin/s3qlctrl
new file mode 100755
index 0000000..6b2535a
--- /dev/null
+++ b/bin/s3qlctrl
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+s3qlctrl - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) 2010 Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.ctrl
+s3ql.cli.ctrl.main(sys.argv[1:])
diff --git a/bin/s3qllock b/bin/s3qllock
new file mode 100755
index 0000000..69b18ae
--- /dev/null
+++ b/bin/s3qllock
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+s3qllock - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.lock
+s3ql.cli.lock.main(sys.argv[1:])
diff --git a/bin/s3qlrm b/bin/s3qlrm
new file mode 100755
index 0000000..beabf06
--- /dev/null
+++ b/bin/s3qlrm
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+s3qlrm - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.remove
+s3ql.cli.remove.main(sys.argv[1:])
diff --git a/bin/s3qlstat b/bin/s3qlstat
new file mode 100755
index 0000000..df7a5bf
--- /dev/null
+++ b/bin/s3qlstat
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+s3qlstat - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) 2008-2009 Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.statfs
+s3ql.cli.statfs.main(sys.argv[1:])
diff --git a/bin/umount.s3ql b/bin/umount.s3ql
new file mode 100755
index 0000000..9db3e70
--- /dev/null
+++ b/bin/umount.s3ql
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+'''
+umount.s3ql - this file is part of S3QL (http://s3ql.googlecode.com)
+
+Copyright (C) 2008-2009 Nikolaus Rath <Nikolaus@rath.org>
+
+This program can be distributed under the terms of the GNU LGPL.
+'''
+
+from __future__ import unicode_literals, division, print_function
+
+import sys
+import os.path
+
+# We are running from the S3QL source directory, make sure
+# that we use modules from this directory
+basedir = os.path.abspath(os.path.join(os.path.dirname(sys.argv[0]), '..'))
+if (os.path.exists(os.path.join(basedir, 'setup.py')) and
+ os.path.exists(os.path.join(basedir, 'src', 's3ql', '__init__.py'))):
+ sys.path = [os.path.join(basedir, 'src')] + sys.path
+
+import s3ql.cli.umount
+s3ql.cli.umount.main(sys.argv[1:]) \ No newline at end of file