summaryrefslogtreecommitdiff
path: root/rst
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2016-03-09 10:08:31 -0800
committerNikolaus Rath <Nikolaus@rath.org>2016-03-09 10:08:31 -0800
commit3caad2930aec3a2af013eb98d9e231f3f6abb93f (patch)
treec4206545fef08c62473a7f7cdf122e6fc2b73c87 /rst
parentdcdc33cc51b7e4fd4d370df89d5e42377cb04e51 (diff)
Import s3ql_1.7.orig.tar.bz2
Diffstat (limited to 'rst')
-rw-r--r--rst/backends.rst11
-rw-r--r--rst/installation.rst21
-rw-r--r--rst/issues.rst22
3 files changed, 20 insertions, 34 deletions
diff --git a/rst/backends.rst b/rst/backends.rst
index 5bc9521..002793f 100644
--- a/rst/backends.rst
+++ b/rst/backends.rst
@@ -154,11 +154,11 @@ problems.
S3 compatible
=============
-S3QL is also able to access other, S3 compatible storage services for
-which no specific backend exists. Note that when accessing such
-services, only the lowest common denominator of available features can
-be used, so it is generally recommended to use a service specific
-backend instead.
+S3QL is also able to access other, S3 compatible storage services like
+OpenStack_ for which no specific backend exists. Note that when
+accessing such services, only the lowest common denominator of
+available features can be used, so it is generally recommended to use
+a service specific backend instead.
The storage URL for accessing an arbitrary S3 compatible storage
service is ::
@@ -173,6 +173,7 @@ to use HTTPS connections. Note, however, that at this point S3QL does
not verify the server certificate (cf. `issue 267
<http://code.google.com/p/s3ql/issues/detail?id=267>`_).
+.. _OpenStack: http://www.openstack.org/
Local
=====
diff --git a/rst/installation.rst b/rst/installation.rst
index 0cfa670..6056906 100644
--- a/rst/installation.rst
+++ b/rst/installation.rst
@@ -34,7 +34,7 @@ that is not the case.
possible*.
* `Python <http://www.python.org/>`_, version 2.6.6 or newer, but not
- Python 3.x.
+ Python 3.x. Make sure to also install the development headers.
* The `PyCrypto++ Python Module
<http://pypi.python.org/pypi/pycryptopp>`_. To check if this module
@@ -46,13 +46,19 @@ that is not the case.
argparse.__version__'`. If argparse is installed, this will print
the version number. You need version 1.1 or later.
+* `SQLite <http://www.sqlite.org/>`_ version 3.7.0 or newer. SQLite
+ has to be installed as a *shared library* with development headers.
+
* The `APSW Python Module <http://code.google.com/p/apsw/>`_. To check
which (if any) version of APWS is installed, run the command ::
- python -c 'import apsw; print apsw.apswversion(), apsw.sqlitelibversion()'
+ python -c 'import apsw; print apsw.apswversion()'
- If APSW is installed, this should print two version numbers which
- both have to be at least 3.7.0.
+ The printed version number should be at least 3.7.0. Note that APSW
+ must be linked *dynamically* against SQLite, so you can *not* use
+ the Ubuntu PPA at
+ https://launchpad.net/~ubuntu-rogerbinns/+archive/apsw (these
+ packages are statically linked).
* The `PyLibLZMA Python module
<http://pypi.python.org/pypi/pyliblzma>`_. To check if this module
@@ -64,9 +70,9 @@ that is not the case.
<http://code.google.com/p/python-llfuse/>`_. To check if this module
is installed, execute `python -c 'import llfuse; print
llfuse.__version__'`. This should print a version number. You need at
- least version 0.29.
+ least version 0.36.
- Note that earlier S3QL versions shipped with a builtin version of
+ Note that early S3QL versions shipped with a built-in version of
this module. If you are upgrading from such a version, make sure to
completely remove the old S3QL version first.
@@ -79,7 +85,8 @@ To install S3QL itself, proceed as follows:
1. Download S3QL from http://code.google.com/p/s3ql/downloads/list
2. Unpack it into a folder of your choice
-3. Run `python setup.py test` to run a self-test. If this fails, ask
+3. Run `python setup.py build` to build S3QL.
+4. Run `python setup.py test` to run a self-test. If this fails, ask
for help on the `mailing list
<http://groups.google.com/group/s3ql>`_ or report a bug in the
`issue tracker <http://code.google.com/p/s3ql/issues/list>`_.
diff --git a/rst/issues.rst b/rst/issues.rst
index ac2cb8c..e79b2e1 100644
--- a/rst/issues.rst
+++ b/rst/issues.rst
@@ -45,28 +45,6 @@ Known Issues
the `--noleaf` option to work correctly on S3QL file systems. This
bug has already been fixed in recent find versions.
-
-* In theory, S3QL is not fully compatible with NFS. Since S3QL does
- not support *inode generation numbers*, NFS clients may (once again,
- in theory) accidentally read or write the wrong file in the
- following situation:
-
- #. An S3QL file system is exported over NFS
- #. NFS client 1 opens a file A
- #. Another NFS client 2 (or the server itself) deletes file A (without
- client 1 knowing about this)
- #. A new file B is created by either of the clients or the server
- #. NFS client 1 tries to read or write file A (which has actually already been deleted).
-
- In this situation it is possible that NFS client 1 actually writes
- or reads the newly created file B instead. The chances of this are 1
- to (2^32 - *n*) where *n* is the total number of directory entries
- in the S3QL file system (as displayed by `s3qlstat`).
-
- Luckily enough, as long as you have less than about 2 thousand
- million directory entries (2^31), the chances for this are totally
- irrelevant and you don't have to worry about it.
-
* The `umount` and `fusermount -u` commands will *not* block until all
data has been uploaded to the backend. (this is a FUSE limitation
that will hopefully be removed in the future, see `issue 159