summaryrefslogtreecommitdiff
path: root/patches/ignore_cython_warnings.diff
diff options
context:
space:
mode:
Diffstat (limited to 'patches/ignore_cython_warnings.diff')
-rw-r--r--patches/ignore_cython_warnings.diff34
1 files changed, 34 insertions, 0 deletions
diff --git a/patches/ignore_cython_warnings.diff b/patches/ignore_cython_warnings.diff
new file mode 100644
index 0000000..48188f7
--- /dev/null
+++ b/patches/ignore_cython_warnings.diff
@@ -0,0 +1,34 @@
+From c1a178861185e4f94feb36e7a4f7ff6da644b66f Mon Sep 17 00:00:00 2001
+From: Nikolaus Rath <Nikolaus@rath.org>
+Date: Tue, 23 Feb 2016 15:44:51 -0800
+Subject: Ignore compiler warnings due to old Cython version
+
+Origin: debian
+Forwarded: not-needed
+Patch-Name: ignore_cython_warnings.diff
+
+Cython versions prior to 0.24 generate Gcc compiler warnings.
+Since Cython 0.24 isn't in Debian yet, we ignore these warnings.
+---
+ setup.py | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index ae1c0..e2c9a 100755
+--- a/setup.py
++++ b/setup.py
+@@ -111,14 +111,6 @@ def main():
+
+ compile_args = ['-Wall', '-Wextra', '-Wconversion', '-Wsign-compare']
+
+- # Value-changing conversions should always be explicit.
+- compile_args.append('-Werror=conversion')
+-
+- # Note that (i > -1) is false if i is unsigned (-1 will be converted to
+- # a large positive value). We certainly don't want to do this by
+- # accident.
+- compile_args.append('-Werror=sign-compare')
+-
+ # Enable all fatal warnings only when compiling from Mercurial tip.
+ # (otherwise we break forward compatibility because compilation with newer
+ # compiler may fail if additional warnings are added)