summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 93a8e52..3ea858f 100755
--- a/setup.py
+++ b/setup.py
@@ -98,9 +98,8 @@ class build_docs(setuptools.Command):
print('Running pdflatex...')
for _ in range(3):
- with open('/dev/null', 'wb') as null:
- subprocess.check_call(['pdflatex', '-interaction', 'batchmode', 'manual.tex'],
- cwd=os.path.join(dest_dir, 'latex'), stdout=null)
+ subprocess.check_call(['pdflatex', '-interaction', 'nonstopmode', 'manual.tex'],
+ cwd=os.path.join(dest_dir, 'latex'))
os.rename(os.path.join(dest_dir, 'latex', 'manual.pdf'),
os.path.join(dest_dir, 'manual.pdf'))