summaryrefslogtreecommitdiff
path: root/src/s3ql.egg-info
diff options
context:
space:
mode:
Diffstat (limited to 'src/s3ql.egg-info')
-rw-r--r--src/s3ql.egg-info/PKG-INFO113
-rw-r--r--src/s3ql.egg-info/SOURCES.txt229
-rw-r--r--src/s3ql.egg-info/dependency_links.txt1
-rw-r--r--src/s3ql.egg-info/entry_points.txt12
-rw-r--r--src/s3ql.egg-info/requires.txt5
-rw-r--r--src/s3ql.egg-info/top_level.txt1
-rw-r--r--src/s3ql.egg-info/zip-safe1
7 files changed, 362 insertions, 0 deletions
diff --git a/src/s3ql.egg-info/PKG-INFO b/src/s3ql.egg-info/PKG-INFO
new file mode 100644
index 0000000..015c3a4
--- /dev/null
+++ b/src/s3ql.egg-info/PKG-INFO
@@ -0,0 +1,113 @@
+Metadata-Version: 1.1
+Name: s3ql
+Version: 1.0.1
+Summary: a full-featured file system for online data storage
+Home-page: http://code.google.com/p/s3ql/
+Author: Nikolaus Rath
+Author-email: Nikolaus@rath.org
+License: LGPL
+Download-URL: http://code.google.com/p/s3ql/downloads/list
+Description: .. -*- mode: rst -*-
+
+ ============
+ About S3QL
+ ============
+
+ S3QL is a file system that stores all its data online. It supports
+ `Amazon S3 <http://aws.amazon.com/s3 Amazon S3>`_ as well as arbitrary
+ SFTP servers and effectively provides you with a hard disk of dynamic,
+ infinite capacity that can be accessed from any computer with internet
+ access.
+
+ S3QL is providing a standard, full featured UNIX file system that is
+ conceptually indistinguishable from any local file system.
+ Furthermore, S3QL has additional features like compression,
+ encryption, data de-duplication, immutable trees and snapshotting
+ which make it especially suitable for online backup and archival.
+
+ S3QL is designed to favor simplicity and elegance over performance and
+ feature-creep. Care has been taken to make the source code as
+ readable and serviceable as possible. Solid error detection and error
+ handling have been included from the very first line, and S3QL comes
+ with extensive automated test cases for all its components.
+
+ Features
+ ========
+
+
+ * **Transparency.** Conceptually, S3QL is indistinguishable from a
+ local file system. For example, it supports hardlinks, symlinks,
+ ACLs and standard unix permissions, extended attributes and file
+ sizes up to 2 TB.
+
+ * **Dynamic Size.** The size of an S3QL file system grows and shrinks
+ dynamically as required.
+
+ * **Compression.** Before storage, all data may compressed with the
+ LZMA, bzip2 or deflate (gzip) algorithm.
+
+ * **Encryption.** After compression (but before upload), all data can
+ AES encrypted with a 256 bit key. An additional SHA256 HMAC checksum
+ is used to protect the data against manipulation.
+
+ * **Data De-duplication.** If several files have identical contents,
+ the redundant data will be stored only once. This works across all
+ files stored in the file system, and also if only some parts of the
+ files are identical while other parts differ.
+
+ * **Immutable Trees.** Directory trees can be made immutable, so that
+ their contents can no longer be changed in any way whatsoever. This
+ can be used to ensure that backups can not be modified after they
+ have been made.
+
+ * **Copy-on-Write/Snapshotting.** S3QL can replicate entire directory
+ trees without using any additional storage space. Only if one of the
+ copies is modified, the part of the data that has been modified will
+ take up additional storage space. This can be used to create
+ intelligent snapshots that preserve the state of a directory at
+ different points in time using a minimum amount of space.
+
+ * **High Performance independent of network latency.** All operations
+ that do not write or read file contents (like creating directories
+ or moving, renaming, and changing permissions of files and
+ directories) are very fast because they are carried out without any
+ network transactions.
+
+ S3QL achieves this by saving the entire file and directory structure
+ in a database. This database is locally cached and the remote
+ copy updated asynchronously.
+
+ * **Support for low bandwidth connections.** S3QL splits file contents
+ into smaller blocks and caches blocks locally. This minimizes both
+ the number of network transactions required for reading and writing
+ data, and the amount of data that has to be transferred when only
+ parts of a file are read or written.
+
+
+
+ Development Status
+ ==================
+
+ After two years of beta-testing by about 93 users did not reveal any
+ data-critical bugs, S3QL was declared **stable** with the release of
+ version 1.0 on May 13th, 2011. Note that this does not mean that S3QL
+ is bug-free. S3QL still has several known, and probably many more
+ unknown bugs. However, there is a high probability that these bugs
+ will, although being inconvenient, not endanger any stored data.
+
+ Please report any problems on the `mailing list
+ <http://groups.google.com/group/s3ql>`_ or the `issue tracker
+ <http://code.google.com/p/s3ql/issues/list>`_.
+
+Keywords: FUSE,backup,archival,compression,encryption,deduplication,aws,s3
+Platform: POSIX
+Platform: UNIX
+Platform: Linux
+Classifier: Development Status :: 4 - Beta
+Classifier: Environment :: No Input/Output (Daemon)
+Classifier: Environment :: Console
+Classifier: License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)
+Classifier: Topic :: Internet
+Classifier: Operating System :: POSIX
+Classifier: Topic :: System :: Archiving
+Provides: s3ql
diff --git a/src/s3ql.egg-info/SOURCES.txt b/src/s3ql.egg-info/SOURCES.txt
new file mode 100644
index 0000000..828f8ca
--- /dev/null
+++ b/src/s3ql.egg-info/SOURCES.txt
@@ -0,0 +1,229 @@
+Changes.txt
+INSTALL.txt
+setup.py
+bin/fsck.s3ql
+bin/mkfs.s3ql
+bin/mount.s3ql
+bin/s3qladm
+bin/s3qlcp
+bin/s3qlctrl
+bin/s3qllock
+bin/s3qlrm
+bin/s3qlstat
+bin/umount.s3ql
+contrib/benchmark.py
+contrib/expire_backups.1
+contrib/expire_backups.py
+contrib/make_dummy.py
+contrib/pcp.1
+contrib/pcp.py
+contrib/s3ql.conf
+contrib/s3ql_backup.sh
+doc/manual.pdf
+doc/html/.buildinfo
+doc/html/about.html
+doc/html/adm.html
+doc/html/backends.html
+doc/html/contrib.html
+doc/html/fsck.html
+doc/html/index.html
+doc/html/installation.html
+doc/html/issues.html
+doc/html/mkfs.html
+doc/html/mount.html
+doc/html/objects.inv
+doc/html/resources.html
+doc/html/search.html
+doc/html/searchindex.js
+doc/html/special.html
+doc/html/tips.html
+doc/html/umount.html
+doc/html/_sources/about.txt
+doc/html/_sources/adm.txt
+doc/html/_sources/backends.txt
+doc/html/_sources/contrib.txt
+doc/html/_sources/fsck.txt
+doc/html/_sources/index.txt
+doc/html/_sources/installation.txt
+doc/html/_sources/issues.txt
+doc/html/_sources/mkfs.txt
+doc/html/_sources/mount.txt
+doc/html/_sources/resources.txt
+doc/html/_sources/special.txt
+doc/html/_sources/tips.txt
+doc/html/_sources/umount.txt
+doc/html/_sources/man/adm.txt
+doc/html/_sources/man/cp.txt
+doc/html/_sources/man/ctrl.txt
+doc/html/_sources/man/expire_backups.txt
+doc/html/_sources/man/fsck.txt
+doc/html/_sources/man/index.txt
+doc/html/_sources/man/lock.txt
+doc/html/_sources/man/mkfs.txt
+doc/html/_sources/man/mount.txt
+doc/html/_sources/man/pcp.txt
+doc/html/_sources/man/rm.txt
+doc/html/_sources/man/stat.txt
+doc/html/_sources/man/umount.txt
+doc/html/_static/ajax-loader.gif
+doc/html/_static/basic.css
+doc/html/_static/comment-bright.png
+doc/html/_static/comment-close.png
+doc/html/_static/comment.png
+doc/html/_static/contents.png
+doc/html/_static/doctools.js
+doc/html/_static/down-pressed.png
+doc/html/_static/down.png
+doc/html/_static/file.png
+doc/html/_static/jquery.js
+doc/html/_static/minus.png
+doc/html/_static/navigation.png
+doc/html/_static/plus.png
+doc/html/_static/pygments.css
+doc/html/_static/searchtools.js
+doc/html/_static/sphinxdoc.css
+doc/html/_static/underscore.js
+doc/html/_static/up-pressed.png
+doc/html/_static/up.png
+doc/html/_static/websupport.js
+doc/html/man/adm.html
+doc/html/man/cp.html
+doc/html/man/ctrl.html
+doc/html/man/expire_backups.html
+doc/html/man/fsck.html
+doc/html/man/index.html
+doc/html/man/lock.html
+doc/html/man/mkfs.html
+doc/html/man/mount.html
+doc/html/man/pcp.html
+doc/html/man/rm.html
+doc/html/man/stat.html
+doc/html/man/umount.html
+doc/latex/Makefile
+doc/latex/fncychap.sty
+doc/latex/manual.aux
+doc/latex/manual.idx
+doc/latex/manual.log
+doc/latex/manual.out
+doc/latex/manual.tex
+doc/latex/manual.toc
+doc/latex/python.ist
+doc/latex/sphinx.sty
+doc/latex/sphinxhowto.cls
+doc/latex/sphinxmanual.cls
+doc/latex/tabulary.sty
+doc/man/fsck.s3ql.1
+doc/man/mkfs.s3ql.1
+doc/man/mount.s3ql.1
+doc/man/s3qladm.1
+doc/man/s3qlcp.1
+doc/man/s3qlctrl.1
+doc/man/s3qllock.1
+doc/man/s3qlrm.1
+doc/man/s3qlstat.1
+doc/man/umount.s3ql.1
+rst/about.rst
+rst/adm.rst
+rst/backends.rst
+rst/conf.py
+rst/contrib.rst
+rst/fsck.rst
+rst/index.rst
+rst/installation.rst
+rst/issues.rst
+rst/mkfs.rst
+rst/mount.rst
+rst/resources.rst
+rst/special.rst
+rst/tips.rst
+rst/umount.rst
+rst/_static/sphinxdoc.css
+rst/_templates/layout.html
+rst/include/about.rst
+rst/include/backends.rst
+rst/include/postman.rst
+rst/man/adm.rst
+rst/man/cp.rst
+rst/man/ctrl.rst
+rst/man/expire_backups.rst
+rst/man/fsck.rst
+rst/man/index.rst
+rst/man/lock.rst
+rst/man/mkfs.rst
+rst/man/mount.rst
+rst/man/pcp.rst
+rst/man/rm.rst
+rst/man/stat.rst
+rst/man/umount.rst
+src/s3ql/__init__.py
+src/s3ql/block_cache.py
+src/s3ql/common.py
+src/s3ql/daemonize.py
+src/s3ql/database.py
+src/s3ql/fs.py
+src/s3ql/fsck.py
+src/s3ql/inode_cache.py
+src/s3ql/multi_lock.py
+src/s3ql/ordered_dict.py
+src/s3ql/parse_args.py
+src/s3ql/thread_group.py
+src/s3ql/upload_manager.py
+src/s3ql.egg-info/PKG-INFO
+src/s3ql.egg-info/SOURCES.txt
+src/s3ql.egg-info/dependency_links.txt
+src/s3ql.egg-info/entry_points.txt
+src/s3ql.egg-info/requires.txt
+src/s3ql.egg-info/top_level.txt
+src/s3ql.egg-info/zip-safe
+src/s3ql/backends/__init__.py
+src/s3ql/backends/common.py
+src/s3ql/backends/ftp.py
+src/s3ql/backends/ftplib.py
+src/s3ql/backends/local.py
+src/s3ql/backends/s3.py
+src/s3ql/backends/sftp.py
+src/s3ql/backends/boto/__init__.py
+src/s3ql/backends/boto/connection.py
+src/s3ql/backends/boto/exception.py
+src/s3ql/backends/boto/handler.py
+src/s3ql/backends/boto/resultset.py
+src/s3ql/backends/boto/storage_uri.py
+src/s3ql/backends/boto/utils.py
+src/s3ql/backends/boto/pyami/__init__.py
+src/s3ql/backends/boto/pyami/config.py
+src/s3ql/backends/boto/s3/__init__.py
+src/s3ql/backends/boto/s3/acl.py
+src/s3ql/backends/boto/s3/bucket.py
+src/s3ql/backends/boto/s3/bucketlistresultset.py
+src/s3ql/backends/boto/s3/connection.py
+src/s3ql/backends/boto/s3/key.py
+src/s3ql/backends/boto/s3/prefix.py
+src/s3ql/backends/boto/s3/user.py
+src/s3ql/cli/__init__.py
+src/s3ql/cli/adm.py
+src/s3ql/cli/cp.py
+src/s3ql/cli/ctrl.py
+src/s3ql/cli/fsck.py
+src/s3ql/cli/lock.py
+src/s3ql/cli/mkfs.py
+src/s3ql/cli/mount.py
+src/s3ql/cli/remove.py
+src/s3ql/cli/statfs.py
+src/s3ql/cli/umount.py
+tests/__init__.py
+tests/_common.py
+tests/data.tar.bz2
+tests/t1_backends.py
+tests/t1_multi_lock.py
+tests/t1_ordered_dict.py
+tests/t2_block_cache.py
+tests/t3_fs_api.py
+tests/t3_fsck.py
+tests/t3_inode_cache.py
+tests/t4_adm.py
+tests/t4_fuse.py
+tests/t5_cli.py
+tests/t5_cp.py
+util/cmdline_lexer.py
+util/distribute_setup.py
+util/sphinx_pipeinclude.py \ No newline at end of file
diff --git a/src/s3ql.egg-info/dependency_links.txt b/src/s3ql.egg-info/dependency_links.txt
new file mode 100644
index 0000000..8b13789
--- /dev/null
+++ b/src/s3ql.egg-info/dependency_links.txt
@@ -0,0 +1 @@
+
diff --git a/src/s3ql.egg-info/entry_points.txt b/src/s3ql.egg-info/entry_points.txt
new file mode 100644
index 0000000..1d80f48
--- /dev/null
+++ b/src/s3ql.egg-info/entry_points.txt
@@ -0,0 +1,12 @@
+[console_scripts]
+fsck.s3ql = s3ql.cli.fsck:main
+s3qllock = s3ql.cli.lock:main
+s3qladm = s3ql.cli.adm:main
+s3qlctrl = s3ql.cli.ctrl:main
+umount.s3ql = s3ql.cli.umount:main
+s3qlcp = s3ql.cli.cp:main
+s3qlrm = s3ql.cli.remove:main
+mount.s3ql = s3ql.cli.mount:main
+s3qlstat = s3ql.cli.statfs:main
+mkfs.s3ql = s3ql.cli.mkfs:main
+
diff --git a/src/s3ql.egg-info/requires.txt b/src/s3ql.egg-info/requires.txt
new file mode 100644
index 0000000..be48a76
--- /dev/null
+++ b/src/s3ql.egg-info/requires.txt
@@ -0,0 +1,5 @@
+apsw >= 3.7.0
+pycryptopp
+llfuse >= 0.31
+argparse >= 1.1
+pyliblzma >= 0.5.3 \ No newline at end of file
diff --git a/src/s3ql.egg-info/top_level.txt b/src/s3ql.egg-info/top_level.txt
new file mode 100644
index 0000000..9d43dc9
--- /dev/null
+++ b/src/s3ql.egg-info/top_level.txt
@@ -0,0 +1 @@
+s3ql
diff --git a/src/s3ql.egg-info/zip-safe b/src/s3ql.egg-info/zip-safe
new file mode 100644
index 0000000..8b13789
--- /dev/null
+++ b/src/s3ql.egg-info/zip-safe
@@ -0,0 +1 @@
+