summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-x[-rw-r--r--]debian/sass-elisp.emacsen-install1
2 files changed, 9 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ea5a8d5..5b2f771 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+sass-elisp (3.0.15-4.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Patch sass-elisp.emacsen-install to ensure that haml-elisp is in the
+ load path during byte-compilation of sass-elisp (Closes: #856681).
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sat, 04 Mar 2017 08:55:25 -0700
+
sass-elisp (3.0.15-4) unstable; urgency=low
* auto-mode-alisp pattern should ends with "\\"
diff --git a/debian/sass-elisp.emacsen-install b/debian/sass-elisp.emacsen-install
index 7fb6794..08dc66d 100644..100755
--- a/debian/sass-elisp.emacsen-install
+++ b/debian/sass-elisp.emacsen-install
@@ -31,6 +31,7 @@ if [ "${FLAVOR}" != "emacs" ]; then
cd /usr/share/${FLAVOR}/site-lisp/sass-elisp
cat <<EOF > path.el
(setq load-path (cons "." load-path) byte-compile-warnings nil)
+(add-to-list 'load-path "/usr/share/emacs/site-lisp/haml-elisp")
EOF
FLAVORTEST=`echo $FLAVOR | cut -c-6`
if [ ${FLAVORTEST} = xemacs ] ; then