summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--debian/control7
-rwxr-xr-xdebian/rules6
3 files changed, 5 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 899732b..e1002a7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ sdcv (0.5.0~beta2-1) UNRELEASED; urgency=low
- All patches incorporated upstream.
- Should fix searching for frequent words (Closes: #680281).
* Use canonical VCS URLs in debian/control.
+ * Adjust debian/rules to new CMake based build system.
-- Michal Čihař <nijel@debian.org> Tue, 10 Sep 2013 08:45:31 +0200
diff --git a/debian/control b/debian/control
index 7bdef38..a40be31 100644
--- a/debian/control
+++ b/debian/control
@@ -4,15 +4,12 @@ Section: utils
Maintainer: Michal Čihař <nijel@debian.org>
Build-Depends: debhelper (>= 9),
dpkg-dev (>= 1.16.1~),
+ cmake,
gettext,
zlib1g-dev,
pkg-config,
libglib2.0-dev,
- libreadline-dev,
- autotools-dev,
- autoconf,
- autopoint,
- automake
+ libreadline-dev
Standards-Version: 3.9.4
Homepage: http://sdcv.sourceforge.net/
Vcs-Browser: http://anonscm.debian.org/viewvc/collab-maint/deb-maint/sdcv/trunk/
diff --git a/debian/rules b/debian/rules
index b289077..b11a1b0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,13 +3,11 @@
#export DH_VERBOSE=1
override_dh_auto_configure:
- autoreconf -f -i
- dh_auto_configure -- --with-readline
- $(MAKE) -C po update-gmo
+ dh_auto_configure -- -DBUILD_TESTS=ON
override_dh_auto_test:
mkdir -p tmphome/.stardict/dic
- HOME=`pwd`/tmphome/; export HOME; $(MAKE) check
+ export HOME=`pwd`/tmphome/; dh_auto_test
%:
dh $@