summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2017-09-11 10:46:39 +0200
committerDidier Raboud <odyx@debian.org>2017-09-11 10:48:18 +0200
commit7c18afb0d02de40da3aa20540516b01fddf904df (patch)
treecf340aec15e4d36f718713159dc996bcbb22382a
parentfcd6aa3adfacc7914455ccd229682e009a06c447 (diff)
Use CMAKE_INSTALL targets
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 148c747..33758f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,10 +76,11 @@ if(BUILD_EXAMPLES)
endif()
# Installation
+include(GNUInstallDirs)
INSTALL(FILES ${HEADERS} DESTINATION include/kitchensink/)
INSTALL(TARGETS SDL_kitchensink SDL_kitchensink_static
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)