summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2020-07-24 14:49:59 +0200
committerDidier Raboud <odyx@debian.org>2020-07-24 14:51:46 +0200
commit95046f200c3f5ae3645aea1a2f6ec06680631310 (patch)
tree79dbee407489458914167975bf4c24ed774010ae
parent683d3cc6bcddd8d28b7aaed2fdb4a2ba8a26f223 (diff)
Pass -fcommon in CFLAGS to circumvent gcc-10 FTBFS
Closes: #957784
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 2920c41..30d98a1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,14 @@
include /usr/share/dpkg/architecture.mk
+# Circumvent GCC-10 FTBFS
+### A common mistake in C is omitting extern when declaring a global variable in
+### a header file. If the header is included by several files it results in
+### multiple definitions of the same variable. In previous GCC versions this
+### error is ignored. GCC 10 defaults to -fno-common, which means a linker error
+### will now be reported.
+export DEB_CFLAGS_MAINT_APPEND = -fcommon
+
%:
dh $@