summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTuomas Virtanen <katajakasa@gmail.com>2018-06-21 02:02:14 +0300
committerTuomas Virtanen <katajakasa@gmail.com>2018-06-21 02:02:14 +0300
commit96fbbaae3957943693de48b3538e7f394ffb9e07 (patch)
treef064c2e6e70c31bc00e18ec49a4cb8419e05d889 /CMakeLists.txt
parenta8bf8500abd2a998759e18211226a9ec6db0edb8 (diff)
Add a custom source creation function
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99a0287..53a5f55 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,23 +93,21 @@ configure_file(
if(BUILD_EXAMPLES)
add_executable(exampleaudio examples/example_audio.c)
add_executable(examplevideo examples/example_video.c)
+ add_executable(examplecustvideo examples/example_cust_video.c)
if(MINGW)
target_link_libraries(exampleaudio mingw32)
target_link_libraries(examplevideo mingw32)
+ target_link_libraries(examplecustvideo mingw32)
endif()
set_property(TARGET exampleaudio PROPERTY C_STANDARD 99)
set_property(TARGET examplevideo PROPERTY C_STANDARD 99)
+ set_property(TARGET examplecustvideo PROPERTY C_STANDARD 99)
- target_link_libraries(exampleaudio
- SDL_kitchensink_static
- ${LIBRARIES}
- )
- target_link_libraries(examplevideo
- SDL_kitchensink_static
- ${LIBRARIES}
- )
+ target_link_libraries(exampleaudio SDL_kitchensink_static ${LIBRARIES})
+ target_link_libraries(examplevideo SDL_kitchensink_static ${LIBRARIES})
+ target_link_libraries(examplecustvideo SDL_kitchensink_static ${LIBRARIES})
endif()
# Installation