summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTuomas Virtanen <katajakasa@gmail.com>2018-06-27 00:14:46 +0300
committerTuomas Virtanen <katajakasa@gmail.com>2018-06-27 00:14:46 +0300
commitc7fc4f2ca9a0d750f32a9f6cf7c86cd2ac548d0f (patch)
tree0ec40d874f357a06bcce7499ad7a97226b938f7c /CMakeLists.txt
parent3884cbb01d5b652a72fa576f226e2312a1512376 (diff)
Add documentation cmake target
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16c45bc..b6a0646 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -109,6 +109,9 @@ if(BUILD_EXAMPLES)
target_link_libraries(custom SDL_kitchensink_static ${LIBRARIES})
endif()
+# documentation target
+add_custom_target(docs COMMAND doxygen WORKING_DIRECTORY ${PROJECT_SOURCE_DIR})
+
# Installation
install(FILES ${PKG_CONFIG_FILE} DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
install(FILES ${INSTALL_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/kitchensink)