summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2017-09-11 10:46:39 +0200
committerDidier Raboud <odyx@debian.org>2017-09-13 09:27:49 +0200
commitec27746ce8d7faa2073fb939e72f1f4f51332472 (patch)
tree517572a8c044d1f001028e0e2ae9859e5353323b /CMakeLists.txt
parent3235ac16899da92ecc554c0d3eae3cdb071d94be (diff)
Use CMAKE_INSTALL targets
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9eca76..14e4e3b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,10 +79,11 @@ if(BUILD_EXAMPLES)
endif()
# Installation
+include(GNUInstallDirs)
INSTALL(FILES ${HEADERS} DESTINATION include/kitchensink/)
INSTALL(TARGETS SDL_kitchensink SDL_kitchensink_static
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)