summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTuomas Virtanen <katajakasa@gmail.com>2016-01-17 22:46:18 +0200
committerTuomas Virtanen <katajakasa@gmail.com>2016-01-17 22:46:18 +0200
commit766a346e516a58fd110caca311ecaec68b47bc12 (patch)
tree189acf02cec11701e48d7a94e9748c83deb46baa /CMakeLists.txt
parentdefe24601e2338a6a6d3145220e25c56bf1c3147 (diff)
Add support for libass subtitles
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8df027..7f05496 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ option(BUILD_EXAMPLES "Build examples" OFF)
option(BUILD_TESTS "Build unittests" OFF)
find_package(SDL2)
+find_package(ass)
find_package(ffmpeg COMPONENTS avcodec avformat avutil swscale swresample)
if(BUILD_TESTS)
@@ -31,6 +32,7 @@ include_directories(
include/
${SDL2_INCLUDE_DIRS}
${FFMPEG_INCLUDE_DIRS}
+ ${ASS_INCLUDE_DIRS}
)
FILE(GLOB SOURCES "src/*.c")
@@ -47,6 +49,7 @@ target_compile_options(SDL_kitchensink PRIVATE "-fvisibility=hidden")
target_link_libraries(SDL_kitchensink
${SDL2_LIBRARIES}
${FFMPEG_LIBRARIES}
+ ${ASS_LIBRARIES}
)
if(BUILD_EXAMPLES)
@@ -62,11 +65,13 @@ if(BUILD_EXAMPLES)
SDL_kitchensink_static
${SDL2_LIBRARIES}
${FFMPEG_LIBRARIES}
+ ${ASS_LIBRARIES}
)
target_link_libraries(examplevideo
SDL_kitchensink_static
${SDL2_LIBRARIES}
${FFMPEG_LIBRARIES}
+ ${ASS_LIBRARIES}
)
endif()