summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTuomas Virtanen <katajakasa@gmail.com>2018-07-02 10:34:09 +0300
committerGitHub <noreply@github.com>2018-07-02 10:34:09 +0300
commit7aec12156a3dc3df570855cb1c3fa03792f77030 (patch)
tree6b1d66e504982e24dcf79c710126ce96457c75ef /CMakeLists.txt
parentf602daa42a2a9135daa9b9a57e177edfb0c767ba (diff)
parent5973307722d4531dd24ff7ada8ab11111f5ee378 (diff)
Merge pull request #42 from katajakasa/source-cleanups
Source cleanups + RWOps
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a822008..023692f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -90,23 +90,27 @@ if(BUILD_EXAMPLES)
add_executable(complex examples/example_complex.c)
add_executable(simple examples/example_simple.c)
add_executable(custom examples/example_custom.c)
+ add_executable(rwops examples/example_rwops.c)
if(MINGW)
target_link_libraries(audio mingw32)
target_link_libraries(complex mingw32)
target_link_libraries(simple mingw32)
target_link_libraries(custom mingw32)
+ target_link_libraries(rwops mingw32)
endif()
set_property(TARGET audio PROPERTY C_STANDARD 99)
set_property(TARGET complex PROPERTY C_STANDARD 99)
set_property(TARGET simple PROPERTY C_STANDARD 99)
set_property(TARGET custom PROPERTY C_STANDARD 99)
+ set_property(TARGET rwops PROPERTY C_STANDARD 99)
target_link_libraries(audio SDL_kitchensink_static ${LIBRARIES})
target_link_libraries(complex SDL_kitchensink_static ${LIBRARIES})
target_link_libraries(simple SDL_kitchensink_static ${LIBRARIES})
target_link_libraries(custom SDL_kitchensink_static ${LIBRARIES})
+ target_link_libraries(rwops SDL_kitchensink_static ${LIBRARIES})
endif()
# documentation target