summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 2920c41..30d98a1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,14 @@
include /usr/share/dpkg/architecture.mk
+# Circumvent GCC-10 FTBFS
+### A common mistake in C is omitting extern when declaring a global variable in
+### a header file. If the header is included by several files it results in
+### multiple definitions of the same variable. In previous GCC versions this
+### error is ignored. GCC 10 defaults to -fno-common, which means a linker error
+### will now be reported.
+export DEB_CFLAGS_MAINT_APPEND = -fcommon
+
%:
dh $@