summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 16 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53a5f55..9a5d90e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,23 +91,27 @@ configure_file(
)
if(BUILD_EXAMPLES)
- add_executable(exampleaudio examples/example_audio.c)
- add_executable(examplevideo examples/example_video.c)
- add_executable(examplecustvideo examples/example_cust_video.c)
+ add_executable(audio examples/example_audio.c)
+ add_executable(complex examples/example_complex.c)
+ add_executable(simple examples/example_simple.c)
+ add_executable(custom examples/example_custom.c)
if(MINGW)
- target_link_libraries(exampleaudio mingw32)
- target_link_libraries(examplevideo mingw32)
- target_link_libraries(examplecustvideo mingw32)
+ target_link_libraries(audio mingw32)
+ target_link_libraries(complex mingw32)
+ target_link_libraries(simple mingw32)
+ target_link_libraries(custom mingw32)
endif()
- set_property(TARGET exampleaudio PROPERTY C_STANDARD 99)
- set_property(TARGET examplevideo PROPERTY C_STANDARD 99)
- set_property(TARGET examplecustvideo PROPERTY C_STANDARD 99)
+ set_property(TARGET audio PROPERTY C_STANDARD 99)
+ set_property(TARGET complex PROPERTY C_STANDARD 99)
+ set_property(TARGET simple PROPERTY C_STANDARD 99)
+ set_property(TARGET custom PROPERTY C_STANDARD 99)
- target_link_libraries(exampleaudio SDL_kitchensink_static ${LIBRARIES})
- target_link_libraries(examplevideo SDL_kitchensink_static ${LIBRARIES})
- target_link_libraries(examplecustvideo SDL_kitchensink_static ${LIBRARIES})
+ target_link_libraries(audio SDL_kitchensink_static ${LIBRARIES})
+ target_link_libraries(complex SDL_kitchensink_static ${LIBRARIES})
+ target_link_libraries(simple SDL_kitchensink_static ${LIBRARIES})
+ target_link_libraries(custom SDL_kitchensink_static ${LIBRARIES})
endif()
# Installation