summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Schauer <josch@debian.org>2017-11-24 11:03:50 +0100
committerJohannes Schauer <josch@debian.org>2017-11-24 11:03:50 +0100
commitb11fb579de79b79ec4663662aa4391f4eb5aa7c8 (patch)
tree08dff78bbe6333f248a81667524e0b690bdb9405
parente8a118a7f1096234eb3d23f9c965a591540ec7f6 (diff)
Commit Debian 3.0 (quilt) metadata
[dgit (4.1) quilt-fixup]
-rw-r--r--debian/patches/debian-changes140
1 files changed, 123 insertions, 17 deletions
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index 003b3eb..7522f40 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -14,18 +14,35 @@ version 1.2.3, you could use:
(If you have dgit, use `dgit clone searx`, rather than plain `git clone`.)
A single combined diff, containing all the changes, follows.
---- searx-0.12.0+dfsg1.orig/manage.sh
-+++ searx-0.12.0+dfsg1/manage.sh
-@@ -88,7 +88,6 @@ styles() {
- build_style themes/legacy/less/style-rtl.less themes/legacy/css/style-rtl.css
- build_style themes/courgette/less/style.less themes/courgette/css/style.css
- build_style themes/courgette/less/style-rtl.less themes/courgette/css/style-rtl.css
-- build_style less/bootstrap/bootstrap.less css/bootstrap.min.css
- build_style themes/oscar/less/pointhi/oscar.less themes/oscar/css/pointhi.min.css
- build_style themes/oscar/less/logicodev/oscar.less themes/oscar/css/logicodev.min.css
- build_style themes/pix-art/less/style.less themes/pix-art/css/style.css
---- searx-0.12.0+dfsg1.orig/searx/settings.yml
-+++ searx-0.12.0+dfsg1/searx/settings.yml
+--- searx-0.13.1+dfsg1.orig/manage.sh
++++ searx-0.13.1+dfsg1/manage.sh
+@@ -93,7 +93,7 @@ tests() {
+ }
+
+ build_style() {
+- lessc --clean-css="--s1 --advanced --compatibility=ie9" "$BASE_DIR/searx/static/$1" "$BASE_DIR/searx/static/$2"
++ lessc -x "$BASE_DIR/searx/static/$1" "$BASE_DIR/searx/static/$2"
+ }
+
+ styles() {
+@@ -104,11 +104,10 @@ styles() {
+ build_style themes/courgette/less/style-rtl.less themes/courgette/css/style-rtl.css
+ build_style less/bootstrap/bootstrap.less css/bootstrap.min.css
+ build_style themes/pix-art/less/style.less themes/pix-art/css/style.css
+- # built using grunt
+- #build_style themes/oscar/less/pointhi/oscar.less themes/oscar/css/pointhi.min.css
+- #build_style themes/oscar/less/logicodev/oscar.less themes/oscar/css/logicodev.min.css
+- #build_style themes/simple/less/style.less themes/simple/css/searx.min.css
+- #build_style themes/simple/less/style-rtl.less themes/simple/css/searx-rtl.min.css
++ build_style themes/oscar/less/pointhi/oscar.less themes/oscar/css/pointhi.min.css
++ build_style themes/oscar/less/logicodev/oscar.less themes/oscar/css/logicodev.min.css
++ build_style themes/simple/less/style.less themes/simple/css/searx.min.css
++ build_style themes/simple/less/style-rtl.less themes/simple/css/searx-rtl.min.css
+ }
+
+ npm_packages() {
+--- searx-0.13.1+dfsg1.orig/searx/settings.yml
++++ searx-0.13.1+dfsg1/searx/settings.yml
@@ -16,8 +16,8 @@ server:
http_protocol_version : "1.0" # 1.0 and 1.1 are supported
@@ -37,9 +54,9 @@ A single combined diff, containing all the changes, follows.
default_theme : oscar # ui theme
default_locale : "" # Default interface locale - leave blank to detect from browser information or use codes from the 'locales' config section
---- searx-0.12.0+dfsg1.orig/searx/static/themes/oscar/gruntfile.js
-+++ searx-0.12.0+dfsg1/searx/static/themes/oscar/gruntfile.js
-@@ -75,16 +75,9 @@ module.exports = function(grunt) {
+--- searx-0.13.1+dfsg1.orig/searx/static/themes/oscar/gruntfile.js
++++ searx-0.13.1+dfsg1/searx/static/themes/oscar/gruntfile.js
+@@ -79,16 +79,9 @@ module.exports = function(grunt) {
}
});
@@ -59,8 +76,97 @@ A single combined diff, containing all the changes, follows.
+ grunt.registerTask('default', ['concat', 'uglify']);
};
---- searx-0.12.0+dfsg1.orig/setup.py
-+++ searx-0.12.0+dfsg1/setup.py
+--- searx-0.13.1+dfsg1.orig/searx/static/themes/simple/gruntfile.js
++++ searx-0.13.1+dfsg1/searx/static/themes/simple/gruntfile.js
+@@ -58,12 +58,6 @@ module.exports = function(grunt) {
+ production: {
+ options: {
+ paths: ["less"],
+- plugins: [
+- new (require('less-plugin-clean-css'))({
+- advanced: true,
+- compatibility: 'ie8'
+- })
+- ],
+ banner: '/*! searx | <%= grunt.template.today("dd-mm-yyyy") %> | https://github.com/asciimoo/searx */\n'
+ },
+ files: {
+@@ -137,15 +131,8 @@ module.exports = function(grunt) {
+ }
+ });
+
+- grunt.loadNpmTasks('grunt-contrib-watch');
+- grunt.loadNpmTasks('grunt-contrib-uglify');
+- grunt.loadNpmTasks('grunt-contrib-jshint');
+- grunt.loadNpmTasks('grunt-contrib-concat');
+- grunt.loadNpmTasks('grunt-contrib-less');
+- grunt.loadNpmTasks('grunt-contrib-cssmin');
+- grunt.loadNpmTasks('grunt-webfont');
++ grunt.loadNpmTasks('grunt-contrib-uglify', '/usr/lib/nodejs');
++ grunt.loadNpmTasks('grunt-contrib-concat', '/usr/lib/nodejs');
+
+- grunt.registerTask('test', ['jshint']);
+-
+- grunt.registerTask('default', ['jshint', 'concat', 'uglify', 'less:development', 'less:production']);
++ grunt.registerTask('default', ['concat', 'uglify']);
+ };
+--- searx-0.13.1+dfsg1.orig/searx/static/themes/simple/js/searx_src/autocomplete.js
++++ searx-0.13.1+dfsg1/searx/static/themes/simple/js/searx_src/autocomplete.js
+@@ -1,4 +1,51 @@
+-(function(f){if(typeof exports==="object"&&typeof module!=="undefined"){module.exports=f()}else if(typeof define==="function"&&define.amd){define([],f)}else{var g;if(typeof window!=="undefined"){g=window}else if(typeof global!=="undefined"){g=global}else if(typeof self!=="undefined"){g=self}else{g=this}g.AutoComplete = f()}})(function(){var define,module,exports;return (function e(t,n,r){function s(o,u){if(!n[o]){if(!t[o]){var a=typeof require=="function"&&require;if(!u&&a)return a(o,!0);if(i)return i(o,!0);var f=new Error("Cannot find module '"+o+"'");throw f.code="MODULE_NOT_FOUND",f}var l=n[o]={exports:{}};t[o][0].call(l.exports,function(e){var n=t[o][1][e];return s(n?n:e)},l,l.exports,e,t,n,r)}return n[o].exports}var i=typeof require=="function"&&require;for(var o=0;o<r.length;o++)s(r[o]);return s})({1:[function(require,module,exports){
++(function(f){
++ if(typeof exports=== "object" && typeof module !== "undefined") {
++ module.exports = f()
++ } else if(typeof define === "function" && define.amd) {
++ define([], f)
++ }else{
++ var g;
++ if(typeof window !== "undefined") {
++ g = window
++ } else if(typeof global !== "undefined") {
++ g = global
++ } else if(typeof self !== "undefined") {
++ g = self
++ } else {
++ g = this
++ }
++ g.AutoComplete = f()
++ }
++})(function(){
++ var define, module, exports;
++ return (function e(t, n, r){
++ function s(o, u){
++ if(!n[o]){
++ if(!t[o]){
++ var a = typeof require == "function" && require;
++ if(!u && a)
++ return a(o, !0);
++ if(i)
++ return i(o, !0);
++ var f = new Error("Cannot find module '" + o + "'");
++ throw f.code = "MODULE_NOT_FOUND", f
++ }
++ var l = n[o] = {
++ exports:{}
++ };
++ t[o][0].call(l.exports,function(e) {
++ var n = t[o][1][e];
++ return s(n?n:e)
++ }, l, l.exports, e, t, n, r)
++ }
++ return n[o].exports
++ }
++ var i = typeof require == "function" && require;
++ for(var o = 0; o < r.length; o++)
++ s(r[o]);
++ return s
++ })({
++ 1:[function(require, module, exports){
+ /*
+ * @license MIT
+ *
+--- searx-0.13.1+dfsg1.orig/setup.py
++++ searx-0.13.1+dfsg1/setup.py
@@ -51,23 +51,9 @@ setup(
},
package_data={