summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Schauer <josch@debian.org>2017-11-24 09:35:29 +0100
committerJohannes Schauer <josch@debian.org>2017-11-24 10:59:24 +0100
commit0598e7ff3daa217df2897e55e5ccd5804b29ec32 (patch)
tree05f88b1cb34df3784c28737e915ca90d888536d9
parentd24cbd76c37db953351cf7d6182d74f9591ae310 (diff)
run wrap-and-sort -asbt
-rw-r--r--debian/control67
-rw-r--r--debian/python3-searx.install12
-rw-r--r--debian/python3-searx.links6
3 files changed, 44 insertions, 41 deletions
diff --git a/debian/control b/debian/control
index 409e2cf..5fba9c1 100644
--- a/debian/control
+++ b/debian/control
@@ -5,27 +5,42 @@ Maintainer: Johannes Schauer <josch@debian.org>
Build-depends:
debhelper (>= 10),
dh-python,
- python3-all,
- python3-setuptools,
- node-less,
- python3-babel,
grunt,
+ node-grunt-contrib-concat,
node-grunt-contrib-uglify,
- node-grunt-contrib-concat
+ node-less,
+ python3-all,
+ python3-babel,
+ python3-setuptools,
X-Python3-Version: >= 3.2
Standards-Version: 4.1.1
Homepage: https://github.com/asciimoo/searx/
Vcs-Git: https://git.dgit.debian.org/searx
Vcs-Browser: https://browse.dgit.debian.org/searx.git/
-Package: searx
+Package: python3-searx
Architecture: all
Depends:
- ${python3:Depends},
+ libjs-bootstrap,
+ libjs-jquery,
+ libjs-leaflet,
+ node-requirejs,
+ python3-certifi,
+ python3-dateutil,
+ python3-flask,
+ python3-flask-babel,
+ python3-lxml,
+ python3-ndg-httpsclient,
+ python3-openssl,
+ python3-pyasn1,
+ python3-pygments,
+ python3-requests,
+ python3-werkzeug,
+ python3-yaml,
${misc:Depends},
- python3-searx (= ${source:Version})
-Suggests: nginx, uwsgi, uwsgi-plugin-python3
-Description: Privacy-respecting metasearch engine
+ ${python3:Depends},
+Section: python
+Description: Privacy-respecting metasearch engine - library package
Searx is an internet metasearch engine which aggregates results from more than
70 search services. Searx runs as a web service and provides a web interface
that allows the user to do a general search (aggregating results from google,
@@ -34,30 +49,20 @@ Description: Privacy-respecting metasearch engine
wiki), maps (OpenStreetMap, photon), music (youtube, spotify, soundcloud),
news (bing news, google news, reddit), science (arxiv, wolframalpha) social
media (digg, twitter) and videos (youtube, dailymotion, vimeo).
+ .
+ This package provides the Python library.
-Package: python3-searx
+Package: searx
Architecture: all
Depends:
- ${python3:Depends},
+ python3-searx (= ${source:Version}),
${misc:Depends},
- python3-certifi,
- python3-yaml,
- python3-pygments,
- python3-werkzeug,
- python3-flask,
- python3-flask-babel,
- python3-lxml,
- python3-dateutil,
- python3-openssl,
- python3-ndg-httpsclient,
- python3-pyasn1,
- python3-requests,
- libjs-bootstrap,
- libjs-jquery,
- node-requirejs,
- libjs-leaflet
-Section: python
-Description: Privacy-respecting metasearch engine - library package
+ ${python3:Depends},
+Suggests:
+ nginx,
+ uwsgi,
+ uwsgi-plugin-python3,
+Description: Privacy-respecting metasearch engine
Searx is an internet metasearch engine which aggregates results from more than
70 search services. Searx runs as a web service and provides a web interface
that allows the user to do a general search (aggregating results from google,
@@ -66,5 +71,3 @@ Description: Privacy-respecting metasearch engine - library package
wiki), maps (OpenStreetMap, photon), music (youtube, spotify, soundcloud),
news (bing news, google news, reddit), science (arxiv, wolframalpha) social
media (digg, twitter) and videos (youtube, dailymotion, vimeo).
- .
- This package provides the Python library.
diff --git a/debian/python3-searx.install b/debian/python3-searx.install
index d32b01d..ab6a3cf 100644
--- a/debian/python3-searx.install
+++ b/debian/python3-searx.install
@@ -1,6 +1,6 @@
-usr/lib/python3*
-# we must list each theme subdirectory manually because we do not want to
# install the less subdirectory or the oscar gruntfile or package.json
+# we must list each theme subdirectory manually because we do not want to
+searx/static/plugins /usr/share/python3-searx/static
searx/static/themes/courgette/css /usr/share/python3-searx/static/themes/courgette
searx/static/themes/courgette/img /usr/share/python3-searx/static/themes/courgette
searx/static/themes/courgette/js /usr/share/python3-searx/static/themes/courgette
@@ -10,11 +10,11 @@ searx/static/themes/legacy/js /usr/share/python3-searx/static/themes/legacy
searx/static/themes/oscar/css /usr/share/python3-searx/static/themes/oscar
searx/static/themes/oscar/img /usr/share/python3-searx/static/themes/oscar
searx/static/themes/oscar/js /usr/share/python3-searx/static/themes/oscar
-searx/static/themes/simple/css /usr/share/python3-searx/static/themes/simple
-searx/static/themes/simple/img /usr/share/python3-searx/static/themes/simple
-searx/static/themes/simple/js /usr/share/python3-searx/static/themes/simple
searx/static/themes/pix-art/css /usr/share/python3-searx/static/themes/pix-art
searx/static/themes/pix-art/img /usr/share/python3-searx/static/themes/pix-art
searx/static/themes/pix-art/js /usr/share/python3-searx/static/themes/pix-art
-searx/static/plugins /usr/share/python3-searx/static
+searx/static/themes/simple/css /usr/share/python3-searx/static/themes/simple
+searx/static/themes/simple/img /usr/share/python3-searx/static/themes/simple
+searx/static/themes/simple/js /usr/share/python3-searx/static/themes/simple
searx/templates /usr/share/python3-searx
+usr/lib/python3*
diff --git a/debian/python3-searx.links b/debian/python3-searx.links
index 6221afc..ded8510 100644
--- a/debian/python3-searx.links
+++ b/debian/python3-searx.links
@@ -1,8 +1,8 @@
+/usr/lib/nodejs/requirejs/require.min.js /usr/share/python3-searx/static/js/require-2.1.15.min.js
+/usr/share/javascript/bootstrap/css/bootstrap.min.css /usr/share/python3-searx/static/css/bootstrap.min.css
/usr/share/javascript/bootstrap/fonts/glyphicons-halflings-regular.ttf /usr/share/python3-searx/static/fonts/glyphicons-halflings-regular.ttf
/usr/share/javascript/bootstrap/fonts/glyphicons-halflings-regular.woff /usr/share/python3-searx/static/fonts/glyphicons-halflings-regular.woff
/usr/share/javascript/bootstrap/fonts/glyphicons-halflings-regular.woff2 /usr/share/python3-searx/static/fonts/glyphicons-halflings-regular.woff2
-/usr/share/javascript/bootstrap/css/bootstrap.min.css /usr/share/python3-searx/static/css/bootstrap.min.css
-/usr/share/javascript/jquery/jquery.min.js /usr/share/python3-searx/static/js/jquery-1.11.1.min.js
/usr/share/javascript/bootstrap/js/bootstrap.js /usr/share/python3-searx/static/js/bootstrap.min.js
-/usr/lib/nodejs/requirejs/require.min.js /usr/share/python3-searx/static/js/require-2.1.15.min.js
+/usr/share/javascript/jquery/jquery.min.js /usr/share/python3-searx/static/js/jquery-1.11.1.min.js
/usr/share/javascript/leaflet/leaflet.css /usr/share/python3-searx/static/css/leaflet.min.css