summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Schauer Marin Rodrigues <josch@debian.org>2022-09-25 08:59:09 +0200
committerJohannes Schauer Marin Rodrigues <josch@debian.org>2022-09-25 08:59:09 +0200
commitda0f49939d8207f6c7d443dcbf7967ee85f61f66 (patch)
tree46881fc624a2debcca173bb9e5c5a2956448c6df
parentdfe5e45ffb909ba79edc782b6dfbcaa491e2636f (diff)
run wrap-and-sort -astb
-rw-r--r--debian/control4
-rw-r--r--debian/python3-searx.install10
-rw-r--r--debian/python3-searx.links2
-rw-r--r--debian/searx.examples2
-rw-r--r--debian/searx.install2
-rw-r--r--debian/tests/control15
6 files changed, 23 insertions, 12 deletions
diff --git a/debian/control b/debian/control
index af64eef..5ea9a1a 100644
--- a/debian/control
+++ b/debian/control
@@ -11,8 +11,8 @@ Build-Depends:
node-less,
python3-all,
python3-babel,
- python3-setuptools,
python3-fontforge,
+ python3-setuptools,
python3-yaml,
Standards-Version: 4.5.0
Homepage: https://asciimoo.github.io/searx/
@@ -40,10 +40,10 @@ Depends:
${misc:Depends},
${python3:Depends},
Suggests:
+ libapache2-mod-uwsgi,
nginx | apache2 | httpd,
uwsgi,
uwsgi-plugin-python3,
- libapache2-mod-uwsgi
Section: python
Description: Privacy-respecting metasearch engine - library package
Searx is an internet metasearch engine which aggregates results from more than
diff --git a/debian/python3-searx.install b/debian/python3-searx.install
index 970cc14..def1807 100644
--- a/debian/python3-searx.install
+++ b/debian/python3-searx.install
@@ -1,14 +1,14 @@
-# we must list each theme subdirectory manually because we do not want to
# install the less subdirectory or the oscar gruntfile or package.json
-searx/static/plugins/js /usr/share/python3-searx/static/plugins
+# we must list each theme subdirectory manually because we do not want to
+debian/ionicons/ion.ttf /usr/share/python3-searx/static/fonts
+debian/ionicons/ion.woff /usr/share/python3-searx/static/fonts
+searx/static/css /usr/share/python3-searx/static
searx/static/plugins/css /usr/share/python3-searx/static/plugins
+searx/static/plugins/js /usr/share/python3-searx/static/plugins
searx/static/themes/oscar/css /usr/share/python3-searx/static/themes/oscar
searx/static/themes/oscar/img /usr/share/python3-searx/static/themes/oscar
searx/static/themes/oscar/js /usr/share/python3-searx/static/themes/oscar
searx/static/themes/simple/img /usr/share/python3-searx/static/themes/simple
searx/static/themes/simple/js /usr/share/python3-searx/static/themes/simple
-searx/static/css /usr/share/python3-searx/static
-debian/ionicons/ion.woff /usr/share/python3-searx/static/fonts
-debian/ionicons/ion.ttf /usr/share/python3-searx/static/fonts
searx/templates /usr/share/python3-searx
usr/lib/python3*
diff --git a/debian/python3-searx.links b/debian/python3-searx.links
index 77714f3..9c2ee0f 100644
--- a/debian/python3-searx.links
+++ b/debian/python3-searx.links
@@ -1,4 +1,3 @@
-/usr/share/javascript/requirejs/require.min.js /usr/share/python3-searx/static/js/require-2.1.15.min.js
/usr/share/javascript/bootstrap/css/bootstrap.min.css /usr/share/python3-searx/static/css/bootstrap.min.css
/usr/share/javascript/bootstrap/fonts/glyphicons-halflings-regular.ttf /usr/share/python3-searx/static/fonts/glyphicons-halflings-regular.ttf
/usr/share/javascript/bootstrap/fonts/glyphicons-halflings-regular.woff /usr/share/python3-searx/static/fonts/glyphicons-halflings-regular.woff
@@ -6,3 +5,4 @@
/usr/share/javascript/bootstrap/js/bootstrap.js /usr/share/python3-searx/static/js/bootstrap.min.js
/usr/share/javascript/jquery/jquery.min.js /usr/share/python3-searx/static/js/jquery.min.js
/usr/share/javascript/leaflet/leaflet.css /usr/share/python3-searx/static/css/leaflet.min.css
+/usr/share/javascript/requirejs/require.min.js /usr/share/python3-searx/static/js/require-2.1.15.min.js
diff --git a/debian/searx.examples b/debian/searx.examples
index e0c43c7..d058f14 100644
--- a/debian/searx.examples
+++ b/debian/searx.examples
@@ -1,4 +1,4 @@
-debian/examples/nginx
debian/examples/apache2
+debian/examples/nginx
debian/examples/uwsgi
searx/settings.yml
diff --git a/debian/searx.install b/debian/searx.install
index abb5e20..d7b677f 100644
--- a/debian/searx.install
+++ b/debian/searx.install
@@ -1,2 +1,2 @@
-usr/bin/searx-run
usr/bin/searx-checker
+usr/bin/searx-run
diff --git a/debian/tests/control b/debian/tests/control
index be344e9..da24578 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,7 +1,18 @@
Tests: nginx
Restrictions: allow-stderr, isolation-container, needs-root
-Depends: @, curl, nginx, uwsgi, uwsgi-plugin-python3
+Depends:
+ curl,
+ nginx,
+ uwsgi,
+ uwsgi-plugin-python3,
+ @,
Tests: apache2
Restrictions: allow-stderr, isolation-container, needs-root
-Depends: @, curl, apache2, libapache2-mod-uwsgi, uwsgi, uwsgi-plugin-python3
+Depends:
+ apache2,
+ curl,
+ libapache2-mod-uwsgi,
+ uwsgi,
+ uwsgi-plugin-python3,
+ @,