summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes 'josch' Schauer <josch@debian.org>2019-01-06 23:22:14 +0100
committerJohannes 'josch' Schauer <josch@debian.org>2019-01-06 23:42:24 +0100
commit307af7f9e30a79633df26f2ae7723c318a7bdcfe (patch)
tree4c83529e9996cc5cb36b68a121f6d4b040a37341
parentde341635b7e0d0efd3f7762dccd5f424bcd356d4 (diff)
Commit Debian 3.0 (quilt) metadata
[dgit (6.9) quilt-fixup]
-rw-r--r--debian/patches/debian-changes206
-rw-r--r--debian/patches/series1
2 files changed, 207 insertions, 0 deletions
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
new file mode 100644
index 0000000..d8d360a
--- /dev/null
+++ b/debian/patches/debian-changes
@@ -0,0 +1,206 @@
+The Debian packaging of searx is maintained in git, using the merging workflow
+described in dgit-maint-merge(7). There isn't a patch queue that can be
+represented as a quilt series.
+
+A detailed breakdown of the changes is available from their canonical
+representation - git commits in the packaging repository. For example, to see
+the changes made by the Debian maintainer in the first upload of upstream
+version 1.2.3, you could use:
+
+ % git clone https://git.dgit.debian.org/searx
+ % cd searx
+ % git log --oneline 1.2.3..debian/1.2.3-1 -- . ':!debian'
+
+(If you have dgit, use `dgit clone searx`, rather than plain `git clone`.)
+
+A single combined diff, containing all the changes, follows.
+--- searx-0.15.0+dfsg1.orig/manage.sh
++++ searx-0.15.0+dfsg1/manage.sh
+@@ -110,8 +110,7 @@ tests() {
+ #
+
+ npm_path_setup() {
+- which npm || (printf 'Error: npm is not found\n'; exit 1)
+- export PATH="$(npm bin)":$PATH
++ true
+ }
+
+ npm_packages() {
+@@ -133,7 +132,7 @@ npm_packages() {
+ build_style() {
+ npm_path_setup
+
+- lessc --clean-css="--s1 --advanced --compatibility=ie9" "$BASE_DIR/searx/static/$1" "$BASE_DIR/searx/static/$2"
++ lessc -x "$BASE_DIR/searx/static/$1" "$BASE_DIR/searx/static/$2"
+ }
+
+ styles() {
+@@ -147,8 +146,15 @@ styles() {
+ build_style themes/courgette/less/style-rtl.less themes/courgette/css/style-rtl.css
+ echo '[!] Building pix-art style'
+ build_style themes/pix-art/less/style.less themes/pix-art/css/style.css
+- echo '[!] Building bootstrap style'
+- build_style less/bootstrap/bootstrap.less css/bootstrap.min.css
++ echo '[!] Building simple style'
++ build_style themes/simple/less/style.less themes/simple/css/searx.min.css
++ build_style themes/simple/less/style-rtl.less themes/simple/css/searx-rtl.min.css
++ echo '[!] Building logicodev'
++ build_style themes/oscar/less/logicodev/oscar.less themes/oscar/css/logicodev.min.css
++ echo '[!] Building logicodev-dark'
++ build_style themes/oscar/less/logicodev-dark/oscar.less themes/oscar/css/logicodev-dark.min.css
++ echo '[!] Building pointhi'
++ build_style themes/oscar/less/pointhi/oscar.less themes/oscar/css/pointhi.min.css
+ }
+
+ grunt_build() {
+--- searx-0.15.0+dfsg1.orig/searx/settings.yml
++++ searx-0.15.0+dfsg1/searx/settings.yml
+@@ -18,8 +18,8 @@ server:
+ http_protocol_version : "1.0" # 1.0 and 1.1 are supported
+
+ ui:
+- static_path : "" # Custom static path - leave it blank if you didn't change
+- templates_path : "" # Custom templates path - leave it blank if you didn't change
++ static_path : "/usr/share/python3-searx/static" # Custom static path - leave it blank if you didn't change
++ templates_path : "/usr/share/python3-searx/templates" # Custom templates path - leave it blank if you didn't change
+ default_theme : oscar # ui theme
+ default_locale : "" # Default interface locale - leave blank to detect from browser information or use codes from the 'locales' config section
+ theme_args :
+--- searx-0.15.0+dfsg1.orig/searx/static/themes/oscar/gruntfile.js
++++ searx-0.15.0+dfsg1/searx/static/themes/oscar/gruntfile.js
+@@ -81,16 +81,8 @@ module.exports = function(grunt) {
+ }
+ });
+
+- grunt.loadNpmTasks('grunt-contrib-uglify');
+- grunt.loadNpmTasks('grunt-contrib-jshint');
+- grunt.loadNpmTasks('grunt-contrib-watch');
+- grunt.loadNpmTasks('grunt-contrib-concat');
+- grunt.loadNpmTasks('grunt-contrib-less');
+-
+- grunt.registerTask('test', ['jshint']);
+-
+- grunt.registerTask('default', ['jshint', 'concat', 'uglify', 'less']);
+-
+- grunt.registerTask('styles', ['less']);
++ grunt.loadNpmTasks('grunt-contrib-uglify', '/usr/lib/nodejs');
++ grunt.loadNpmTasks('grunt-contrib-concat', '/usr/lib/nodejs');
+
++ grunt.registerTask('default', ['concat', 'uglify']);
+ };
+--- searx-0.15.0+dfsg1.orig/searx/static/themes/simple/gruntfile.js
++++ searx-0.15.0+dfsg1/searx/static/themes/simple/gruntfile.js
+@@ -64,12 +64,6 @@ module.exports = function(grunt) {
+ production: {
+ options: {
+ paths: ["less"],
+- plugins: [
+- new (require('less-plugin-clean-css'))({
+- advanced: true,
+- compatibility: '*'
+- })
+- ],
+ banner: '/*! searx | <%= grunt.template.today("dd-mm-yyyy") %> | https://github.com/asciimoo/searx */\n'
+ },
+ files: {
+@@ -144,15 +138,8 @@ module.exports = function(grunt) {
+ }
+ });
+
+- grunt.loadNpmTasks('grunt-contrib-watch');
+- grunt.loadNpmTasks('grunt-contrib-uglify');
+- grunt.loadNpmTasks('grunt-contrib-jshint');
+- grunt.loadNpmTasks('grunt-contrib-concat');
+- grunt.loadNpmTasks('grunt-contrib-less');
+- grunt.loadNpmTasks('grunt-contrib-cssmin');
+- grunt.loadNpmTasks('grunt-webfont');
++ grunt.loadNpmTasks('grunt-contrib-uglify', '/usr/lib/nodejs');
++ grunt.loadNpmTasks('grunt-contrib-concat', '/usr/lib/nodejs');
+
+- grunt.registerTask('test', ['jshint']);
+-
+- grunt.registerTask('default', ['jshint', 'concat', 'uglify', 'less:development', 'less:production']);
++ grunt.registerTask('default', ['concat', 'uglify']);
+ };
+--- searx-0.15.0+dfsg1.orig/searx/static/themes/simple/js/searx_src/autocomplete.js
++++ searx-0.15.0+dfsg1/searx/static/themes/simple/js/searx_src/autocomplete.js
+@@ -1,4 +1,51 @@
+-(function(f){if(typeof exports==="object"&&typeof module!=="undefined"){module.exports=f()}else if(typeof define==="function"&&define.amd){define([],f)}else{var g;if(typeof window!=="undefined"){g=window}else if(typeof global!=="undefined"){g=global}else if(typeof self!=="undefined"){g=self}else{g=this}g.AutoComplete = f()}})(function(){var define,module,exports;return (function e(t,n,r){function s(o,u){if(!n[o]){if(!t[o]){var a=typeof require=="function"&&require;if(!u&&a)return a(o,!0);if(i)return i(o,!0);var f=new Error("Cannot find module '"+o+"'");throw f.code="MODULE_NOT_FOUND",f}var l=n[o]={exports:{}};t[o][0].call(l.exports,function(e){var n=t[o][1][e];return s(n?n:e)},l,l.exports,e,t,n,r)}return n[o].exports}var i=typeof require=="function"&&require;for(var o=0;o<r.length;o++)s(r[o]);return s})({1:[function(require,module,exports){
++(function(f){
++ if(typeof exports=== "object" && typeof module !== "undefined") {
++ module.exports = f()
++ } else if(typeof define === "function" && define.amd) {
++ define([], f)
++ }else{
++ var g;
++ if(typeof window !== "undefined") {
++ g = window
++ } else if(typeof global !== "undefined") {
++ g = global
++ } else if(typeof self !== "undefined") {
++ g = self
++ } else {
++ g = this
++ }
++ g.AutoComplete = f()
++ }
++})(function(){
++ var define, module, exports;
++ return (function e(t, n, r){
++ function s(o, u){
++ if(!n[o]){
++ if(!t[o]){
++ var a = typeof require == "function" && require;
++ if(!u && a)
++ return a(o, !0);
++ if(i)
++ return i(o, !0);
++ var f = new Error("Cannot find module '" + o + "'");
++ throw f.code = "MODULE_NOT_FOUND", f
++ }
++ var l = n[o] = {
++ exports:{}
++ };
++ t[o][0].call(l.exports,function(e) {
++ var n = t[o][1][e];
++ return s(n?n:e)
++ }, l, l.exports, e, t, n, r)
++ }
++ return n[o].exports
++ }
++ var i = typeof require == "function" && require;
++ for(var o = 0; o < r.length; o++)
++ s(r[o]);
++ return s
++ })({
++ 1:[function(require, module, exports){
+ /*
+ * @license MIT
+ *
+--- searx-0.15.0+dfsg1.orig/setup.py
++++ searx-0.15.0+dfsg1/setup.py
+@@ -51,23 +51,9 @@ setup(
+ },
+ package_data={
+ 'searx': [
+- 'settings.yml',
+- '../README.rst',
+- '../requirements.txt',
+- '../requirements-dev.txt',
+ 'data/*',
+ 'plugins/*/*',
+- 'static/*.*',
+- 'static/*/*.*',
+- 'static/*/*/*.*',
+- 'static/*/*/*/*.*',
+- 'static/*/*/*/*/*.*',
+- 'templates/*/*.*',
+- 'templates/*/*/*.*',
+- 'tests/*',
+- 'tests/*/*',
+- 'tests/*/*/*',
+- 'translations/*/*/*'
++ 'translations/*/*/*.mo'
+ ],
+ },
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..7bb8252
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+debian-changes