summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Schauer <josch@debian.org>2018-02-20 14:13:52 +0100
committerJohannes Schauer <josch@debian.org>2018-02-21 09:06:25 +0100
commitece08c91cb2c3fea31d92c6b3e04bb2bfdbfe15f (patch)
tree408e91819b0ff89da19f2d723be1891d7a7209f3
parentf6da658cf1d976fdd7847593ba96857e2c14fc8b (diff)
Apply debian specific patches
-rwxr-xr-xmanage.sh17
-rw-r--r--searx/settings.yml4
-rw-r--r--searx/static/themes/oscar/gruntfile.js13
-rw-r--r--searx/static/themes/simple/gruntfile.js19
-rw-r--r--searx/static/themes/simple/js/searx_src/autocomplete.js49
-rw-r--r--setup.py16
6 files changed, 69 insertions, 49 deletions
diff --git a/manage.sh b/manage.sh
index cf31bb5..03bb94b 100755
--- a/manage.sh
+++ b/manage.sh
@@ -1,11 +1,11 @@
-#!/bin/sh
+#!/bin/bash
BASE_DIR="$(dirname -- "`readlink -f -- "$0"`")"
export PATH="$BASE_DIR/node_modules/.bin":$PATH
# the script can be sourced to update the PATH
# see https://stackoverflow.com/questions/2683279/how-to-detect-if-a-script-is-being-sourced
-if [ $_ != $0 ]; then
+if [[ $0 != "$BASH_SOURCE" ]]; then
unset BASE_DIR
# sourced : exit now
return
@@ -132,7 +132,7 @@ npm_packages() {
}
build_style() {
- lessc --clean-css="--s1 --advanced --compatibility=ie9" "$BASE_DIR/searx/static/$1" "$BASE_DIR/searx/static/$2"
+ lessc -x "$BASE_DIR/searx/static/$1" "$BASE_DIR/searx/static/$2"
}
styles() {
@@ -144,8 +144,15 @@ styles() {
build_style themes/courgette/less/style-rtl.less themes/courgette/css/style-rtl.css
echo '[!] Building pix-art style'
build_style themes/pix-art/less/style.less themes/pix-art/css/style.css
- echo '[!] Building bootstrap style'
- build_style less/bootstrap/bootstrap.less css/bootstrap.min.css
+ echo '[!] Building simple style'
+ build_style themes/simple/less/style.less themes/simple/css/searx.min.css
+ build_style themes/simple/less/style-rtl.less themes/simple/css/searx-rtl.min.css
+ echo '[!] Building logicodev'
+ build_style themes/oscar/less/logicodev/oscar.less themes/oscar/css/logicodev.min.css
+ echo '[!] Building logicodev-dark'
+ build_style themes/oscar/less/logicodev-dark/oscar.less themes/oscar/css/logicodev-dark.min.css
+ echo '[!] Building pointhi'
+ build_style themes/oscar/less/pointhi/oscar.less themes/oscar/css/pointhi.min.css
}
grunt_build() {
diff --git a/searx/settings.yml b/searx/settings.yml
index 32b1b3d..5392eb1 100644
--- a/searx/settings.yml
+++ b/searx/settings.yml
@@ -16,8 +16,8 @@ server:
http_protocol_version : "1.0" # 1.0 and 1.1 are supported
ui:
- static_path : "" # Custom static path - leave it blank if you didn't change
- templates_path : "" # Custom templates path - leave it blank if you didn't change
+ static_path : "/usr/share/python3-searx/static" # Custom static path - leave it blank if you didn't change
+ templates_path : "/usr/share/python3-searx/templates" # Custom templates path - leave it blank if you didn't change
default_theme : oscar # ui theme
default_locale : "" # Default interface locale - leave blank to detect from browser information or use codes from the 'locales' config section
diff --git a/searx/static/themes/oscar/gruntfile.js b/searx/static/themes/oscar/gruntfile.js
index 5913994..b86b883 100644
--- a/searx/static/themes/oscar/gruntfile.js
+++ b/searx/static/themes/oscar/gruntfile.js
@@ -81,16 +81,9 @@ module.exports = function(grunt) {
}
});
- grunt.loadNpmTasks('grunt-contrib-uglify');
- grunt.loadNpmTasks('grunt-contrib-jshint');
- grunt.loadNpmTasks('grunt-contrib-watch');
- grunt.loadNpmTasks('grunt-contrib-concat');
- grunt.loadNpmTasks('grunt-contrib-less');
+ grunt.loadNpmTasks('grunt-contrib-uglify', '/usr/lib/nodejs');
+ grunt.loadNpmTasks('grunt-contrib-concat', '/usr/lib/nodejs');
- grunt.registerTask('test', ['jshint']);
-
- grunt.registerTask('default', ['jshint', 'concat', 'uglify', 'less']);
-
- grunt.registerTask('styles', ['less']);
+ grunt.registerTask('default', ['concat', 'uglify']);
};
diff --git a/searx/static/themes/simple/gruntfile.js b/searx/static/themes/simple/gruntfile.js
index 13fd326..1d53319 100644
--- a/searx/static/themes/simple/gruntfile.js
+++ b/searx/static/themes/simple/gruntfile.js
@@ -60,12 +60,6 @@ module.exports = function(grunt) {
production: {
options: {
paths: ["less"],
- plugins: [
- new (require('less-plugin-clean-css'))({
- advanced: true,
- compatibility: 'ie8'
- })
- ],
banner: '/*! searx | <%= grunt.template.today("dd-mm-yyyy") %> | https://github.com/asciimoo/searx */\n'
},
files: {
@@ -139,15 +133,8 @@ module.exports = function(grunt) {
}
});
- grunt.loadNpmTasks('grunt-contrib-watch');
- grunt.loadNpmTasks('grunt-contrib-uglify');
- grunt.loadNpmTasks('grunt-contrib-jshint');
- grunt.loadNpmTasks('grunt-contrib-concat');
- grunt.loadNpmTasks('grunt-contrib-less');
- grunt.loadNpmTasks('grunt-contrib-cssmin');
- grunt.loadNpmTasks('grunt-webfont');
+ grunt.loadNpmTasks('grunt-contrib-uglify', '/usr/lib/nodejs');
+ grunt.loadNpmTasks('grunt-contrib-concat', '/usr/lib/nodejs');
- grunt.registerTask('test', ['jshint']);
-
- grunt.registerTask('default', ['jshint', 'concat', 'uglify', 'less:development', 'less:production']);
+ grunt.registerTask('default', ['concat', 'uglify']);
};
diff --git a/searx/static/themes/simple/js/searx_src/autocomplete.js b/searx/static/themes/simple/js/searx_src/autocomplete.js
index b95fbcf..4bbe017 100644
--- a/searx/static/themes/simple/js/searx_src/autocomplete.js
+++ b/searx/static/themes/simple/js/searx_src/autocomplete.js
@@ -1,4 +1,51 @@
-(function(f){if(typeof exports==="object"&&typeof module!=="undefined"){module.exports=f()}else if(typeof define==="function"&&define.amd){define([],f)}else{var g;if(typeof window!=="undefined"){g=window}else if(typeof global!=="undefined"){g=global}else if(typeof self!=="undefined"){g=self}else{g=this}g.AutoComplete = f()}})(function(){var define,module,exports;return (function e(t,n,r){function s(o,u){if(!n[o]){if(!t[o]){var a=typeof require=="function"&&require;if(!u&&a)return a(o,!0);if(i)return i(o,!0);var f=new Error("Cannot find module '"+o+"'");throw f.code="MODULE_NOT_FOUND",f}var l=n[o]={exports:{}};t[o][0].call(l.exports,function(e){var n=t[o][1][e];return s(n?n:e)},l,l.exports,e,t,n,r)}return n[o].exports}var i=typeof require=="function"&&require;for(var o=0;o<r.length;o++)s(r[o]);return s})({1:[function(require,module,exports){
+(function(f){
+ if(typeof exports=== "object" && typeof module !== "undefined") {
+ module.exports = f()
+ } else if(typeof define === "function" && define.amd) {
+ define([], f)
+ }else{
+ var g;
+ if(typeof window !== "undefined") {
+ g = window
+ } else if(typeof global !== "undefined") {
+ g = global
+ } else if(typeof self !== "undefined") {
+ g = self
+ } else {
+ g = this
+ }
+ g.AutoComplete = f()
+ }
+})(function(){
+ var define, module, exports;
+ return (function e(t, n, r){
+ function s(o, u){
+ if(!n[o]){
+ if(!t[o]){
+ var a = typeof require == "function" && require;
+ if(!u && a)
+ return a(o, !0);
+ if(i)
+ return i(o, !0);
+ var f = new Error("Cannot find module '" + o + "'");
+ throw f.code = "MODULE_NOT_FOUND", f
+ }
+ var l = n[o] = {
+ exports:{}
+ };
+ t[o][0].call(l.exports,function(e) {
+ var n = t[o][1][e];
+ return s(n?n:e)
+ }, l, l.exports, e, t, n, r)
+ }
+ return n[o].exports
+ }
+ var i = typeof require == "function" && require;
+ for(var o = 0; o < r.length; o++)
+ s(r[o]);
+ return s
+ })({
+ 1:[function(require, module, exports){
/*
* @license MIT
*
diff --git a/setup.py b/setup.py
index 6466d1f..1b0ae30 100644
--- a/setup.py
+++ b/setup.py
@@ -51,23 +51,9 @@ setup(
},
package_data={
'searx': [
- 'settings.yml',
- '../README.rst',
- '../requirements.txt',
- '../requirements-dev.txt',
'data/*',
'plugins/*/*',
- 'static/*.*',
- 'static/*/*.*',
- 'static/*/*/*.*',
- 'static/*/*/*/*.*',
- 'static/*/*/*/*/*.*',
- 'templates/*/*.*',
- 'templates/*/*/*.*',
- 'tests/*',
- 'tests/*/*',
- 'tests/*/*/*',
- 'translations/*/*/*'
+ 'translations/*/*/*.mo'
],
},