summaryrefslogtreecommitdiff
path: root/debian/tests
diff options
context:
space:
mode:
authorJohannes 'josch' Schauer <josch@debian.org>2019-01-06 23:54:27 +0100
committerJohannes 'josch' Schauer <josch@debian.org>2020-02-01 01:09:45 +0100
commite6e516f49697d4cb99a80851fbb037f32ac0949d (patch)
tree879c664285baea1e26bbfb6a9e666c117e1e7ca3 /debian/tests
parent3e49246c2e44159486ea66fed3757cdb4e4d0c50 (diff)
Import Debian changes 0.15.0+dfsg1-1
searx (0.15.0+dfsg1-1) unstable; urgency=medium * New upstream release * Use require.min.js from libjs-requirejs and not from nodejs-requirejs (closes: #901738) * Update Homepage field to https://asciimoo.github.io/searx/ (closes: #893679) * Fix my name in Maintainer field * Use secure copyright format uri * Remove X-Python3-Version field * Bump debhelper compat level to 11 searx (0.14.0+dfsg1-2) unstable; urgency=medium * Add "lazy-apps = true" to uwsgi config or otherwise searx searches will timeout. See https://github.com/asciimoo/searx/issues/1210 searx (0.14.0+dfsg1-1) unstable; urgency=medium * New upstream release - settings.yaml can now contain non-ascii characters (closes: #886093) searx (0.13.1+dfsg1-3) unstable; urgency=medium * Add ionicons font to build ion.woff from source using fontforge for the "simple" theme (closes: #882847) searx (0.13.1+dfsg1-2) unstable; urgency=medium * Remove python3-ndg-httpsclient and python3-pyasn1 from Depends of python3-searx. Thanks to Alexandre Flament searx (0.13.1+dfsg1-1) unstable; urgency=medium * New upstream release. (closes: #882400) * also fixes exception when activating image proxy with python3 (closes: #877942) * add debian/gbp.conf * debian/README.source: adjust instructions for debian/gbp.conf * debian/control: bump Standards-Version, no changes required * debian/control: python3-searx is section python * debian/copyright: Add files from the new simple theme to Files-Excluded * debian/copyright: add new contributors for translations * debian/python3-searx.install: also install simple theme * debian/copyright: add copyright for four more files from the simple theme * run wrap-and-sort -asbt searx (0.12.0+dfsg1-1) unstable; urgency=medium * Initial release. (Closes: #808564)
Diffstat (limited to 'debian/tests')
-rw-r--r--debian/tests/control3
-rw-r--r--debian/tests/general15
2 files changed, 18 insertions, 0 deletions
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..dbabf19
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,3 @@
+Tests: general
+Restrictions: allow-stderr, isolation-container, needs-root
+Depends: @, curl, nginx, uwsgi, uwsgi-plugin-python3
diff --git a/debian/tests/general b/debian/tests/general
new file mode 100644
index 0000000..2dfba3f
--- /dev/null
+++ b/debian/tests/general
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+set -ex
+
+rm /etc/nginx/sites-enabled/default
+cp /usr/share/doc/searx/examples/nginx/sites-available/searx /etc/nginx/sites-available
+ln -s ../sites-available/searx /etc/nginx/sites-enabled/searx
+cp /usr/share/doc/searx/examples/uwsgi/apps-available/searx.ini /etc/uwsgi/apps-available
+ln -s ../apps-available/searx.ini /etc/uwsgi/apps-enabled/searx.ini
+mkdir /etc/searx
+gzip --to-stdout --decompress /usr/share/doc/searx/examples/settings.yml.gz > /etc/searx/settings.yml
+sed -i -e "s/ultrasecretkey/$(openssl rand -hex 16)/g" /etc/searx/settings.yml
+systemctl restart nginx
+systemctl restart uwsgi
+curl localhost | grep 'input type="search" name="q"'