summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJohannes Schauer <josch@debian.org>2018-02-21 08:19:53 +0100
committerJohannes Schauer <josch@debian.org>2018-02-21 09:06:28 +0100
commit7c53fda7e82dbd4f13bd6dab74f09ac18b03dc42 (patch)
tree763ab4e4c82ed488c8f74ae915975cf6dcb99ef9 /debian
parentece08c91cb2c3fea31d92c6b3e04bb2bfdbfe15f (diff)
generate ion.less
Diffstat (limited to 'debian')
-rw-r--r--debian/ionicons/generate_less.py69
-rwxr-xr-xdebian/rules1
2 files changed, 70 insertions, 0 deletions
diff --git a/debian/ionicons/generate_less.py b/debian/ionicons/generate_less.py
new file mode 100644
index 0000000..55fdc0c
--- /dev/null
+++ b/debian/ionicons/generate_less.py
@@ -0,0 +1,69 @@
+# /usr/bin/env python3
+#
+# Copyright: 2017 Johannes Schauer <josch@debian.org>
+#
+# Permission is hereby granted, free of charge, to any person obtaining
+# a copy of this software and associated documentation files (the
+# "Software"), to deal in the Software without restriction, including
+# without limitation the rights to use, copy, modify, merge, publish,
+# distribute, sublicense, and/or sell copies of the Software, and to
+# permit persons to whom the Software is furnished to do so, subject to
+# the following conditions:
+#
+# The above copyright notice and this permission notice shall be included
+# in all copies or substantial portions of the Software.
+
+import sys
+import json
+
+args = json.load(sys.stdin)
+
+print("""
+@font-face {
+ font-family:"%s";""" % args["fontFamilyName"])
+
+srcs = []
+for t in args["types"]:
+ if t == "woff":
+ srcs.append("""url("../fonts/ion.woff") format("woff")""")
+ elif t == "woff2":
+ srcs.append("""url("../fonts/ion.woff2") format("woff2")""")
+ elif t == "ttf":
+ srcs.append("""url("../fonts/ion.ttf") format("truetype")""")
+ elif t == "svg":
+ srcs.append("""url("../fonts/ion.svg") format("svg")""")
+ else:
+ raise Exception("unknown font type: %s" % t)
+
+print("\tsrc:%s;" % ",\n\t\t".join(srcs))
+
+print("""
+ font-weight:normal;
+ font-style:normal;
+}
+
+.ion-icon {
+ &:before {
+ font-family:"%s";
+ }
+ display:inline-block;
+ vertical-align:middle;
+ line-height:1;
+ font-weight:normal;
+ font-style:normal;
+ speak:none;
+ text-decoration:inherit;
+ text-transform:none;
+ text-rendering:auto;
+ -webkit-font-smoothing:antialiased;
+ -moz-osx-font-smoothing:grayscale;
+}
+""" % args["fontFamilyName"])
+
+for k in sorted(args["codepoints"].keys()):
+ print("""
+.%s-%s {
+ &:before {
+ content:"\\%s";
+ }
+}""" % (args["fontFamilyName"], k, hex(args["codepoints"][k])[2:]))
diff --git a/debian/rules b/debian/rules
index 82ca952..c1f696b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,7 @@ export PYBUILD_DISABLE_python2=1
dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_build:
+ python ./debian/ionicons/generate_less.py < ./debian/ionicons/input.json > searx/static/themes/simple/less/ion.less
dh_auto_build
./manage.sh styles # needed to run lessc because grunt-contrib-less is not packaged
./manage.sh locales # run pybabel