summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 7ccb17a..82ca952 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,8 @@
#export DH_VERBOSE = 1
+export PYBUILD_DISABLE_python2=1
+
%:
dh $@ --with python3 --buildsystem=pybuild
@@ -10,6 +12,7 @@ override_dh_auto_build:
./manage.sh styles # needed to run lessc because grunt-contrib-less is not packaged
./manage.sh locales # run pybabel
./manage.sh grunt_build # build the oscar theme
+ python ./debian/ionicons/generate.py < ./debian/ionicons/input.json
# do not run tests because the splinter python3 module is not packaged yet
override_dh_auto_test: