summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b978297..c3dabc9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,3 +27,23 @@ override_dh_auto_build:
# do not run tests because the splinter python3 module is not packaged yet
override_dh_auto_test:
+
+execute_after_dh_auto_clean:
+ rm -f debian/ionicons/ion.ttf debian/ionicons/ion.woff searx/data/bangs.json
+ for p in themes/oscar/src/less/pointhi/variables.less \
+ css/logicodev-dark.min.css \
+ css/logicodev.min.css \
+ css/pointhi.min.css \
+ css/searx-rtl.min.css \
+ css/searx.min.css \
+ themes/oscar/js/searx.js \
+ themes/oscar/js/searx.min.js \
+ themes/oscar/js/searx.min.js.map \
+ themes/simple/js/searx.head.min.js \
+ themes/simple/js/searx.head.min.js.map \
+ themes/simple/js/searx.js \
+ themes/simple/js/searx.min.js \
+ themes/simple/js/searx.min.js.map \
+ themes/simple/less/ion.less; do \
+ rm -f "searx/static/$$p"; \
+ done