summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJérémy Bobbio <lunar@debian.org>2015-01-01 11:21:25 +0100
committerClint Adams <clint@debian.org>2015-01-01 11:00:12 -0500
commitfb919e2dd03128e776792e4e3a8768cc32e9cf8f (patch)
tree2c181d9f038501858dc0dc16ae3c965da8332a03 /debian
parent9f2e77ff77765516e198f36caa4e157460a1bdaf (diff)
Stop recording current time when using gzip
To enable sed to be build reproducibly, we stop recording the current time when using gzip.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 26b3fda..f5f777a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -88,8 +88,8 @@ endif
rm -f $(tmpdir)/usr/share/info/dir*
# mv $(tmpdir)/usr/share/doc/sed-4.1.5 $(tmpdir)$(docdir)
# mv $(tmpdir)/usr/share/doc/sed.html $(tmpdir)$(docdir)/
- gzip -9 $(tmpdir)/usr/share/man/man1/*
- gzip -9 $(tmpdir)/usr/share/info/sed.info*
+ gzip -9n $(tmpdir)/usr/share/man/man1/*
+ gzip -9n $(tmpdir)/usr/share/info/sed.info*
# Install some documentation
install -p -o root -g root -m 644 AUTHORS BUGS README THANKS \
@@ -99,7 +99,7 @@ endif
$(tmpdir)$(docdir)/changelog.Debian
install -p -o root -g root -m 644 debian/my/sedfaq.txt $(tmpdir)$(docdir)
# We expect an error here for the examples-subdir
- -gzip -9 $(tmpdir)$(docdir)/*
+ -gzip -9n $(tmpdir)$(docdir)/*
install -p -o root -g root -m 644 debian/copyright $(tmpdir)$(docdir)
install -p -o root -g root -m 644 testsuite/dc.sed $(tmpdir)$(docdir)/examples/