summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog156
1 files changed, 156 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 0c9c30f..2e69026 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,161 @@
+2020-01-14 Jim Meyering <meyering@fb.com>
+
+ version 4.8
+ * NEWS: Record release date.
+
+ doc: mention changes inherited through gnulib
+ * NEWS (Improvements): Mention gnulib.
+
+2020-01-11 Jim Meyering <meyering@fb.com>
+
+ build: update gnulib to latest (for updated perl.m4)
+
+ tests: remove valgrind-added diagnostics from stderr
+ * testsuite/bug32271-2.sh: Filter out lines starting with "==".
+ This avoids unwarranted failures on e.g., windows systems that
+ would emit this to stderr:
+ +==16281== error calling PR_SET_PTRACER, vgdb might block
+ * testsuite/newline-dfa-bug.sh: Likewise.
+ Reported by Vagelis Prokopiou on Windows subsystem for Linux
+ (Debian 10) in https://lists.gnu.org/r/sed-devel/2020-01/msg00018.html
+ and by Bruno Haible for mingw in
+ https://lists.gnu.org/r/sed-devel/2020-01/msg00005.html
+
+ sed: avoid MSVC build failure
+ * sed/sed.c (usage): Remove unnecessary forward declaration.
+ Reported by Bruno Haible in
+ https://lists.gnu.org/r/sed-devel/2020-01/msg00007.html
+
+ tests: avoid hpux11 test failure
+ * testsuite/title-case.sh: Correct printf usage not to trigger
+ unspecified behavior for '\(\)'. Instead, just use sed with its -r
+ option so those parentheses don't need any backslash at all.
+ Reported by Bruno Haible in
+ https://lists.gnu.org/r/sed-devel/2020-01/msg00008.html
+
+2020-01-09 Jim Meyering <meyering@fb.com>
+
+ tests: handle missing perl
+ Before this change, the two perl-requiring tests would fail
+ on systems without perl. Now, they are skipped, as intended.
+ * bootstrap.conf (gnulib_modules): Add perl.
+ * testsuite/no-perl: New file. From coreutils.
+ * testsuite/local.mk (EXTRA_DIST): Add it.
+ (TESTSUITE_PERL): Include testsuite/ prefix.
+
+2020-01-06 Jim Meyering <meyering@fb.com>
+
+ maint: once again distribute .tar.gz files
+ * configure.ac: Reenable distribution of gzip-compressed
+ tarballs, on request from Jan Nieuwenhuizen in
+ https://lists.gnu.org/r/sed-devel/2020-01/msg00013.html
+ * NEWS (Release): Mention this.
+
+2020-01-05 Jim Meyering <meyering@fb.com>
+
+ maint: space-before-open-paren: avoid syntax-check error
+ * sed/sed.c (selinux_support): Insert space before open-paren.
+
+ build: update gnulib to latest (for thread-related test fixes)
+ * .gitignore: Add /lib/inttypes.h.
+
+2020-01-01 Jim Meyering <meyering@fb.com>
+
+ maint: update all copyright year number ranges
+ Run "make update-copyright" and then...
+ * gnulib: Update to latest with copyright year adjusted.
+ * tests/init.sh: Sync with gnulib to pick up copyright year.
+ * bootstrap: Likewise.
+
+ maint: remove explicit mention of gnulib's threadlib module
+ * bootstrap.conf (gnulib_modules): Remove explicit mention of threadlib.
+ It was added back in 2012 to avoid a bootstrap failure; that explicit
+ mention has long been unnecessary.
+
+2019-09-05 Assaf Gordon <assafgordon@gmail.com>
+
+ sed: set correct umask on temporary files
+ "sed -i" now creates temporary files with correct umask (limited to u=rwx).
+ Previously sed would incorrectly set umask, and combined with mkostemp
+ creating file with mode 0600, the result would be a file with
+ permission mode 0.
+
+ Reported by Dr N.W. Filardo <nwf20@cam.ac.uk>:
+ https://lists.gnu.org/r/sed-devel/2019-08/msg00000.html
+ "The net effect is that this patch does not do what it says on the tin:
+ it does not improve the security story at all. Things continue to
+ function because the subsequent operations are via f*() APIs, which
+ take the open file handle, and in particular fchmod() will put the
+ bits back to something sensible.
+
+ However, when running atop, for example, fuse-style filesystems which do
+ not keep open descriptors to underlying files, this is catastrophic:
+ the underlying file will have I_SRWXU of zero, and so the filesystem
+ server will be unable to open the file for the fchmod() and that's
+ the end of that."
+
+ "fuse-overlayfs" is an example of a filesystem with such issues.
+ This change was made in commit 5156c19b23c41f438bf8658e1b9a43a5ff136835
+ and was released in sed 4.2.1.
+
+ * NEWS: Mention change.
+ * sed/utils.c (ck_mkstemp): Set correct umask.
+
+2019-06-02 Assaf Gordon <assafgordon@gmail.com>
+
+ tests: inplace-selinux.sh: skip if SELinux is not supported
+ Avoid false-positive failure on system with SELinux enabled when SED
+ is built without SELinux suppport.
+
+ Reported by Jeffrey Walton <noloader@gmail.com> in
+ https://bugs.gnu.org/35997 .
+
+ * testsuite/inplace-selinux.sh: Call 'sed --version' to check if sed
+ was built with SELinux support before continuing with the test.
+
+2019-06-02 Assaf Gordon <assafgordon@gmail.com>
+
+ sed: report SELinux status in --version output
+ Report whether sed was built with SELinux support (determined at compile
+ time), and whether it is enabled on this system (determined at runtime).
+
+ Relates to https://bugs.gnu.org/35997 .
+
+ * sed/sed.c (selinux_support): New function, print SELinux status to
+ stdout. (main): Call selinux_support on --version.
+
+2019-01-20 Jim Meyering <meyering@fb.com>
+
+ build: ensure no VLA is used
+ Cause developer builds to fail for any use of a VLA.
+ VLAs (variable length arrays) limit portability.
+ * configure.ac (nw): Remove -Wvla from the list of disabled warnings,
+ thus enabling the warning when configured with --enable-gcc-warnings.
+ (GNULIB_NO_VLA) Define, disabling use of VLAs in gnulib. This commit
+ is functionally equivalent to coreutils' v8.30-44-gd26dece5d.
+
+ build: update gnulib to latest
+
+2019-01-01 Jim Meyering <meyering@fb.com>
+
+ build: update gnulib to latest
+
+2019-01-01 Assaf Gordon <assafgordon@gmail.com>
+
+ maint: update copyright dates for 2019
+ * all files: Run "make update-copyright".
+
2018-12-20 Jim Meyering <meyering@fb.com>
+ maint: use https: in gnu mirror URL prefix, not http
+ This appears in the generated release announcement message.
+ * cfg.mk (url_dir_list): Use https: prefix, not http:.
+
+ maint: post-release administrivia
+ * NEWS: Add header line for next release.
+ * .prev-version: Record previous version.
+ * cfg.mk (old_NEWS_hash): Auto-update.
+
version 4.7
* NEWS: Record release date.