summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-30 19:17:21 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2018-07-30 19:17:21 +0000
commit03a4fb92a06f436c89128126d2bd8bf8cfec9fac (patch)
tree20d7ebf3db0dec52467577654533070e464603ec
parentb44641e2e894145aaa56fd29c3e6685e70369a44 (diff)
parent9ec97c8fbf724aeb4283df3375d4a05de18c8e1e (diff)
Update upstream source from tag 'upstream/0_20170901git13cd6f9'
Update to upstream version '0~20170901git13cd6f9' with Debian dir 4c72b7431d0f0f010cf2fbd2f381ff19473897e4
-rw-r--r--.travis.yml6
-rw-r--r--Makefile4
-rw-r--r--README.md13
-rw-r--r--sfarkxtc.cpp4
4 files changed, 23 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..99e02f1
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,6 @@
+language: cpp
+before_install: git clone https://github.com/raboof/sfArkLib.git; cd sfArkLib; make ; sudo make install; cd ..
+script: make
+compiler:
+ - clang
+ - gcc
diff --git a/Makefile b/Makefile
index 0356bd7..88ed301 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,10 @@ all: sfarkxtc
INSTALL?=install
+# Seems to be needed as clang doesn't appear to add this by default on
+# OSX. Let me know if you know a better way.
+LDFLAGS=-L/usr/local/lib
+
LDLIBS=-lsfark -lz
clean:
diff --git a/README.md b/README.md
index 7501293..5496cb3 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,8 @@
sfarkxtc
========
+[![Build Status](https://travis-ci.org/raboof/sfarkxtc.svg?branch=master)](https://travis-ci.org/raboof/sfarkxtc)
+
sfArk extractor, console version
Converts soundfonts in the legacy sfArk v2 file format to sf2
@@ -8,9 +10,16 @@ Converts soundfonts in the legacy sfArk v2 file format to sf2
Building
========
-Prerequisites: zlib and https://github.com/raboof/sfArkLib
+Prerequisites
+-------------
+
+* Install zlib, e.g. from the zlib1g-dev package
+* Build and install sfarklib as described at https://github.com/raboof/sfArkLib
+
+Building
+--------
- $ make
+ $ sudo make install
that's it!
diff --git a/sfarkxtc.cpp b/sfarkxtc.cpp
index 621bc95..8ac5e24 100644
--- a/sfarkxtc.cpp
+++ b/sfarkxtc.cpp
@@ -20,7 +20,7 @@
// based on SDL_Test
// Reads an existing .sfArk file and writes an sf2 file using standard file i/o
-// Return 0 if successful, 1 if some error occured.
+// Return 0 if successful, 1 if some error occurred.
// Info and error messages are printed to stdout
// Initial version, andyi, 14-Sep-2002
@@ -34,7 +34,7 @@ const char *ThisVersion = "3.0-SNAPSHOT"; // Version of program
#include <time.h>
//#include <iostream>
-#include "sfArkLib.h"
+#include <sfArkLib.h>
// Application-supplied functions...
void sfkl_msg(const char *MessageText, int Flags); // Message display function