summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2015-03-15 11:39:30 +0100
committerRuben Undheim <ruben.undheim@gmail.com>2015-03-15 11:39:30 +0100
commit3ed63fd86f2a75890c9c21d1558aafac9072d96f (patch)
tree7b2bcd0cad7bab491f4d3b26ec6a747ebd4c2499
parent81609f539c75ba8c9353fb888c2ddf6b95960baa (diff)
Add changes done by sponsor during upload
-rw-r--r--debian/control9
-rwxr-xr-xdebian/rules4
2 files changed, 7 insertions, 6 deletions
diff --git a/debian/control b/debian/control
index 42d8cda..7b9d6af 100644
--- a/debian/control
+++ b/debian/control
@@ -15,8 +15,9 @@ Package: sfarkxtc
Architecture: any
Depends: ${shlibs:Depends},
${misc:Depends}
-Description: Converts soundfonts in the legacy sfArk v2 file format to sf2
- This is a very small command line tool to convert legacy sfArk files
- into the SoundFont 2 format. It uses the library sfarklib.
+Description: Converts soundfonts from legacy sfArk v2 file format to sf2
+ This very small command line tool converts legacy sfArk files into the
+ SoundFont 2 format.
.
- Unfortunately only sfArk V2+ files are handled by this library.
+ It is based on the library sfarklib, which unfortunately only supports
+ sfArk V2+ files.
diff --git a/debian/rules b/debian/rules
index b9337d9..cc5e673 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,9 +23,9 @@ $(PKG)_$(VER).orig.tar.gz:
git clone git://github.com/raboof/sfarkxtc.git $(PKG)-$(VER)
cd $(PKG)-$(VER) \
&& git checkout `echo $(VER) | perl -pe 's/[\d\.]+?[\+~]\d\d\d\d\d\d\d\dgit(\w\w\w\w\w\w\w)/\1/'` \
- && $(RM) -rf .git
+ && $(RM) -rf .git .gitignore .travis.yml
@echo "# Packing..."
find -L "$(PKG)-$(VER)" -xdev -type f -print | sort \
- | tar -czvf "$(PKG)_$(VER).orig.tar.gz" -T- --owner=root --group=root --mode=a+rX \
+ | GZIP=-9n tar -czvf "$(PKG)_$(VER).orig.tar.gz" -T- --owner=root --group=root --mode=a+rX \
&& $(RM) -rf "$(PKG)-$(VER)"