summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArnout Engelen <arnouten@bzzt.net>2013-08-12 22:32:56 +0200
committerArnout Engelen <arnouten@bzzt.net>2013-12-19 00:50:13 +0100
commit80b1da32ac83babf6594fd7fb404a9b31a2958e7 (patch)
treecb5d38b8fd79bddcf4b2d8e8815569657a79e2c2
parenteb9560cd3920d41c59ea06c5e935f59f72789a6c (diff)
Rename to sfarkxtc
sfark is the name of the original linux sfark console decompression utility. In actual fact this code is based on sfarkxtm: the code for sfarkxtc has been lost to history, but it too was based on sfarkxtm, the mac version of this utility, which was in turn based on the windows tool sfarkxt, all based on the sfArkLib library. This version is intended to replace both sfarkxtm and sfarkxtc and be cross-platform.
-rw-r--r--Makefile8
-rw-r--r--README.md8
-rw-r--r--sfarkxtc.cpp (renamed from sfArkXTm.cpp)2
3 files changed, 10 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 7b45590..0356bd7 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,11 @@
-all: sfArkXTm
+all: sfarkxtc
INSTALL?=install
LDLIBS=-lsfark -lz
clean:
- -rm sfArkXTm
+ -rm sfarkxtc 2>/dev/null || true
-install: sfArkXTm
- $(INSTALL) -D sfArkXTm $(DESTDIR)/usr/local/bin/sfArkXTm
+install: sfarkxtc
+ $(INSTALL) -D sfarkxtc $(DESTDIR)/usr/local/bin/sfarkxtc
diff --git a/README.md b/README.md
index 59458ce..7501293 100644
--- a/README.md
+++ b/README.md
@@ -1,7 +1,9 @@
-sfArkXTm
+sfarkxtc
========
-Basic sfArk to sf2 soundfont converter
+sfArk extractor, console version
+
+Converts soundfonts in the legacy sfArk v2 file format to sf2
Building
========
@@ -15,4 +17,4 @@ that's it!
Usage
=====
- $ ./sfArkXTm somefile.sfArk somefile.sf2
+ $ ./sfarkxtc somefile.sfArk somefile.sf2
diff --git a/sfArkXTm.cpp b/sfarkxtc.cpp
index d644e05..621bc95 100644
--- a/sfArkXTm.cpp
+++ b/sfarkxtc.cpp
@@ -25,7 +25,7 @@
// Initial version, andyi, 14-Sep-2002
-const char *ThisProg = "sfArkXTm";
+const char *ThisProg = "sfarkxtc";
const char *ThisVersion = "3.0-SNAPSHOT"; // Version of program
// Standard includes...