summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-30 19:36:28 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2018-07-30 19:42:36 +0000
commite2dfbd519002c3d6ec390a3798db1433884ed2a7 (patch)
treee1becdb12e6d74784e1766845557a3e8ce86ab62
parent3782ed482227043918f738928e9cbf22eacba626 (diff)
Add patch for propagatgin down LDFLAGS to fix missing bindnow hardening
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/0002-LDFLAGS-propagate-down.patch21
-rw-r--r--debian/patches/01_fix_install_path.patch18
-rw-r--r--debian/patches/series1
4 files changed, 42 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index b28e312..03b7a3b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+sfarkxtc (0~20170901git13cd6f9-2) UNRELEASED; urgency=medium
+
+ * debian/patches/0002-LDFLAGS-propagate-down.patch:
+ - Add patch for propagatgin down LDFLAGS to fix missing bindnow hardening
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Mon, 30 Jul 2018 19:40:25 +0000
+
sfarkxtc (0~20170901git13cd6f9-1) unstable; urgency=medium
* New upstream version
diff --git a/debian/patches/0002-LDFLAGS-propagate-down.patch b/debian/patches/0002-LDFLAGS-propagate-down.patch
new file mode 100644
index 0000000..1dc8d39
--- /dev/null
+++ b/debian/patches/0002-LDFLAGS-propagate-down.patch
@@ -0,0 +1,21 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Mon, 30 Jul 2018 19:35:38 +0000
+Subject: Make sure LDFLAGS is propagated down
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 03decdc..ec813cf 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@ INSTALL?=install
+
+ # Seems to be needed as clang doesn't appear to add this by default on
+ # OSX. Let me know if you know a better way.
+-LDFLAGS=-L/usr/local/lib
++LDFLAGS ?= -L/usr/local/lib
+
+ LDLIBS=-lsfark -lz
+
diff --git a/debian/patches/01_fix_install_path.patch b/debian/patches/01_fix_install_path.patch
index ac9cd25..1afa52f 100644
--- a/debian/patches/01_fix_install_path.patch
+++ b/debian/patches/01_fix_install_path.patch
@@ -1,8 +1,16 @@
-Description: Fixes the install location (usr instead of usr/local)
-Author: Ruben Undheim <ruben.undheim@gmail.com>
---- sfarkxtc-0.20130812git80b1da3.orig/Makefile
-+++ sfarkxtc-0.20130812git80b1da3/Makefile
-@@ -8,4 +8,4 @@ clean:
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Wed, 5 Nov 2014 18:51:11 +0100
+Subject: Fixes the install location (usr instead of usr/local)
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 88ed301..03decdc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -12,4 +12,4 @@ clean:
-rm sfarkxtc 2>/dev/null || true
install: sfarkxtc
diff --git a/debian/patches/series b/debian/patches/series
index b859669..5889b30 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
01_fix_install_path.patch
+0002-LDFLAGS-propagate-down.patch