summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-08-17 09:30:39 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-03-13 07:32:00 +0100
commit3fe905a8d5cc986da8c6d73c12c4ba73bd4b3f4e (patch)
treeebd1ed640f333e254ab3d806bcf30ad9ef88c00d
parentd0071f387bda6420f404b1c7f9d0efadd8379a61 (diff)
add install_requires dependencies
Gbp-Pq: Name 0007-add-install_requires-dependencies.patch
-rw-r--r--setup.py19
1 files changed, 18 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 51f9be2..d214b5a 100644
--- a/setup.py
+++ b/setup.py
@@ -777,7 +777,24 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy",
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # Debian added
+ 'futures;python_version<"3.2"',
+ "ipython",
+ "qtconsole",
+ 'enum34;python_version<"3.4"',
+ "fabio",
+ "h5py",
+ "lxml",
+ "mako",
+ "matplotlib",
+ "PyOpenGL",
+ "pil",
+ "pyopencl",
+ "PyQt5",
+ "scipy",
+ "six"
+ ]
setup_requires = ["setuptools", "numpy"]