summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-08-17 09:30:39 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2017-11-25 17:02:19 +0100
commit908ae0d8a130426b222de60d1d7ff6e565b6f85e (patch)
tree03f08833013e469d5a18cc52aa7d006a832890ee
parent3e0df6c25f113f8c57c202d8edd0d1451acbfb5c (diff)
add install_requires dependencies
Gbp-Pq: Name 0007-add-install_requires-dependencies.patch
-rw-r--r--setup.py18
1 files changed, 17 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bede4df..c41df00 100644
--- a/setup.py
+++ b/setup.py
@@ -701,7 +701,23 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy",
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # Debian added
+ "ipython",
+ "qtconsole",
+ 'enum34;python_version<"3.4"',
+ "fabio",
+ "h5py",
+ "lxml",
+ "mako",
+ "matplotlib",
+ "PyOpenGL",
+ "pil",
+ "pyopencl",
+ "PyQt5",
+ "scipy",
+ "six"
+ ]
setup_requires = ["setuptools", "numpy"]