summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-08-17 09:30:39 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-03-13 20:04:20 +0100
commit8ea8c5db982f9a76a8190daf5962d27fb8a2394f (patch)
treeab4b97468af594fcad096c7ec9a8409ad979b0b0
parent6c8806b49a93902443199673fc3bc9decde93a15 (diff)
add install_requires dependencies
Gbp-Pq: Name 0007-add-install_requires-dependencies.patch
-rw-r--r--setup.py19
1 files changed, 18 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 51f9be2..d214b5a 100644
--- a/setup.py
+++ b/setup.py
@@ -777,7 +777,24 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy",
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # Debian added
+ 'futures;python_version<"3.2"',
+ "ipython",
+ "qtconsole",
+ 'enum34;python_version<"3.4"',
+ "fabio",
+ "h5py",
+ "lxml",
+ "mako",
+ "matplotlib",
+ "PyOpenGL",
+ "pil",
+ "pyopencl",
+ "PyQt5",
+ "scipy",
+ "six"
+ ]
setup_requires = ["setuptools", "numpy"]