summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2019-02-21 11:04:02 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2019-02-21 11:22:03 +0100
commit2103dbf4d1e6be2ff950e93725edef9881f13306 (patch)
treebdea56c51373c7b60c55f21927d4dd6e1fa791de
parentbcf413125b3f493ea3075baed185e291e08a492f (diff)
fix FTBFS with numpy 0.16
Gbp-Pq: Name 0004-fix-FTBFS-with-numpy-0.16.patch
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 40b2e8e..9f6ae13 100644
--- a/setup.py
+++ b/setup.py
@@ -614,8 +614,8 @@ class BuildExt(build_ext):
extern = 'extern "C" ' if ext.language == 'c++' else ''
return_type = 'void' if sys.version_info[0] <= 2 else 'PyObject*'
- ext.extra_compile_args.append(
- '''-fvisibility=hidden -D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))
+ # ext.extra_compile_args.append(
+ # '''-fvisibility=hidden -D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))
def is_debug_interpreter(self):
"""