summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-08-17 09:30:39 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-07-31 16:24:57 +0200
commitaa734c9d1affb2ee3b03e35b06546d9636c428e3 (patch)
tree7efe1910f8551c964c37c82138582d6f91d84d67
parent1ea2a401ab7802f44c8767197f69650984bd4842 (diff)
add install_requires dependencies
Gbp-Pq: Name 0007-add-install_requires-dependencies.patch
-rw-r--r--setup.py19
1 files changed, 18 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bc7ea27..8c4dd3d 100644
--- a/setup.py
+++ b/setup.py
@@ -857,7 +857,24 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy %s" % numpy_requested_version,
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # Debian added
+ 'futures;python_version<"3.2"',
+ "ipython",
+ "qtconsole",
+ 'enum34;python_version<"3.4"',
+ "fabio",
+ "h5py",
+ "lxml",
+ "mako",
+ "matplotlib",
+ "PyOpenGL",
+ "pil",
+ "pyopencl",
+ "PyQt5",
+ "scipy",
+ "six"
+ ]
setup_requires = ["setuptools", "numpy"]