summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2021-09-08 18:01:49 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2021-09-08 18:01:49 +0200
commita5687fee0ee15768d952a101536740c7083a0ae9 (patch)
tree4c3e01d27091dbfc9b82e6d866787526e33f9165
parentbc17a4e9c4ff3d9aa498b03c4d47b523a3bc6565 (diff)
remove useless environment
HOME and XDG_ are now managed via debhelper with level 13
-rwxr-xr-xdebian/rules10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index e4f1f87..b8759f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,9 @@
#!/usr/bin/make -f
# avoir bbuild FTBFS
-export HOME=$(CURDIR)/debian/tmp-home
-export XDG_RUNTIME_DIR=$(HOME)/runtime
-export POCL_CACHE_DIR=$(HOME)/.cache/
+# export HOME=$(CURDIR)/debian/tmp-home
+# export XDG_RUNTIME_DIR=$(HOME)/runtime
+# export POCL_CACHE_DIR=$(HOME)/.cache/
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
@@ -41,7 +41,7 @@ execute_after_dh_auto_build-indep:
# build the documentation
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
- mkdir -p -m 700 $(XDG_RUNTIME_DIR)
+ # mkdir -p -m 700 $(XDG_RUNTIME_DIR)
pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} -m sphinx -N -bhtml source build/html"
endif
@@ -62,7 +62,7 @@ execute_before_dh_install:
# GPU=False to disable the use of a GPU with OpenCL test
# WITH_GL_TEST=False to disable tests using OpenGL
override_dh_auto_test:
- mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
+ # mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False WITH_QT_TEST=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
execute_after_dh_installdocs: