summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-08-02 13:26:59 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-08-02 13:26:59 +0200
commitcf9500b725782cd5ad32517fac122a8f24a24537 (patch)
tree478d48c3af5b753580894bc2344b8b6da89e2cff
parentc279fbca22fe0cf2c6ba78c428b77f1cbef808ee (diff)
Installed qtdesigner files for qt5 only
-rw-r--r--debian/changelog5
-rwxr-xr-xdebian/rules6
2 files changed, 7 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 0559b57..18ac528 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,8 +6,9 @@ silx (0.8.0+dfsg-1) unstable; urgency=medium
- Build-Depends
+ Added pandoc
* d/rules
- - override dh_python3 to deal with qtdesigner files.
- - run sphinx with xvfb in order to have the right silx.sx documentation.
+ - Installed the QtDesigner files only for Qt5.
+ - Override dh_python3 to deal with qtdesigner files.
+ - Run sphinx with xvfb in order to have the right silx.sx documentation.
-- Picca Frédéric-Emmanuel <picca@debian.org> Tue, 31 Jul 2018 16:24:57 +0200
diff --git a/debian/rules b/debian/rules
index ea542b1..3dab5ee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,8 @@ export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
export PYBUILD_NAME=silx
export SPECFILE_USE_GNU_SOURCE=1
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
# Make does not offer a recursive wildcard function, so here's one:
rwildcard=$(wildcard $1$2) $(foreach d,$(wildcard $1*),$(call rwildcard,$d/,$2))
@@ -47,13 +49,13 @@ override_dh_install:
dh_install -p silx package/desktop/silx.xml usr/share/mime/packages
# install the qtdesigner files only for the python3 package
- dh_install -p python3-silx qtdesigner_plugins/*.py /usr/lib/qt4/plugins/designer/python
+ dh_install -p python3-silx qtdesigner_plugins/*.py /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/plugins/designer/python
dh_install
override_dh_python3:
dh_python3
- dh_python3 -p python3-silx /usr/lib/qt4/plugins/designer/python
+ dh_python3 -p python3-silx /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/plugins/designer/python
# WITH_QT_TEST=False to disable graphical tests
# SILX_OPENCL=False to disable OpenCL tests