summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2019-02-21 11:04:02 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2019-02-21 11:05:12 +0100
commitd83c4d280efa48c7d73875432c64481e51196148 (patch)
tree6bc22821f27a74b0715e1018efc4d819d4186e7a
parentd0aae771fea2e52e08dcb642ec63ecfed17f832a (diff)
fix FTBFS with numpy 0.16
Gbp-Pq: Name 0004-fix-FTBFS-with-numpy-0.16.patch
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 40b2e8e..9f6ae13 100644
--- a/setup.py
+++ b/setup.py
@@ -614,8 +614,8 @@ class BuildExt(build_ext):
extern = 'extern "C" ' if ext.language == 'c++' else ''
return_type = 'void' if sys.version_info[0] <= 2 else 'PyObject*'
- ext.extra_compile_args.append(
- '''-fvisibility=hidden -D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))
+ # ext.extra_compile_args.append(
+ # '''-fvisibility=hidden -D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))
def is_debug_interpreter(self):
"""