summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2019-02-21 11:05:12 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2019-02-21 11:17:43 +0100
commit6022cde91ee9c9396fc049de996a1abbd5357a32 (patch)
treef1793d9e83413ba926a475cb47f015a1e0e7b9e3
parent3e5dcad207c1eadeb74fb53f524c3a94fbe19096 (diff)
Import Debian changes 0.9.0+dfsg-2
silx (0.9.0+dfsg-2) unstable; urgency=medium * d/patches: + 0004-fix-FTBFS-with-numpy-0.16.patch (Added)
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/0004-fix-FTBFS-with-numpy-0.16.patch24
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/tests/control.autodep8 (renamed from debian/tests/control)8
5 files changed, 35 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index b644cd1..695e7b5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,9 @@
-silx (0.9.0+dfsg-2) UNRELEASED; urgency=medium
+silx (0.9.0+dfsg-2) unstable; urgency=medium
- * d/t/control.autodep8: Fixed to run test for real.
- * d/rules: Do not run Qt test for now.
+ * d/patches:
+ + 0004-fix-FTBFS-with-numpy-0.16.patch (Added)
- -- Picca Frédéric-Emmanuel <picca@debian.org> Thu, 20 Dec 2018 16:21:18 +0100
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Thu, 21 Feb 2019 11:05:12 +0100
silx (0.9.0+dfsg-1) unstable; urgency=medium
diff --git a/debian/patches/0004-fix-FTBFS-with-numpy-0.16.patch b/debian/patches/0004-fix-FTBFS-with-numpy-0.16.patch
new file mode 100644
index 0000000..bcc32ad
--- /dev/null
+++ b/debian/patches/0004-fix-FTBFS-with-numpy-0.16.patch
@@ -0,0 +1,24 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Thu, 21 Feb 2019 11:04:02 +0100
+Subject: fix FTBFS with numpy 0.16
+
+---
+ setup.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 40b2e8e..9f6ae13 100644
+--- a/setup.py
++++ b/setup.py
+@@ -614,8 +614,8 @@ class BuildExt(build_ext):
+ extern = 'extern "C" ' if ext.language == 'c++' else ''
+ return_type = 'void' if sys.version_info[0] <= 2 else 'PyObject*'
+
+- ext.extra_compile_args.append(
+- '''-fvisibility=hidden -D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))
++ # ext.extra_compile_args.append(
++ # '''-fvisibility=hidden -D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))
+
+ def is_debug_interpreter(self):
+ """
diff --git a/debian/patches/series b/debian/patches/series
index 168097d..57660df 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
0002-use-the-system-mathjax-privacy-breach.patch
0003-fix-unit-test.patch
0003-do-not-modify-PYTHONPATH-from-setup.py.patch
+0004-fix-FTBFS-with-numpy-0.16.patch
diff --git a/debian/rules b/debian/rules
index 7badfa4..501910c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -68,8 +68,8 @@ override_dh_python3:
# UNACTIVATED UNTIL dh_python from UNSTABLE IS FIXED
# https://lists.debian.org/debian-python/2017/08/msg00095.html
override_dh_auto_test:
- mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
- dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False WITH_QT_TEST=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
+# mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
+# dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
override_dh_installman:
dh_installman -p silx build/man/*.1
diff --git a/debian/tests/control b/debian/tests/control.autodep8
index 1e5cddf..5ffa42b 100644
--- a/debian/tests/control
+++ b/debian/tests/control.autodep8
@@ -2,7 +2,7 @@ Test-Command: set -efu
; for py in $(pyversions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import silx.test; silx.test.run_tests()" 2>&1
+ ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -m unittest discover silx 2>&1
; done
Depends: python-all, python-silx, xauth, xvfb
@@ -10,7 +10,7 @@ Test-Command: set -efu
; for py in $(pyversions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py-dbg:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py-dbg -c "import silx.test; silx.test.run_tests()" 2>&1
+ ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py-dbg -m unittest discover silx 2>&1
; done
Depends: python-all-dbg, python-silx-dbg, xauth, xvfb
@@ -18,7 +18,7 @@ Test-Command: set -efu
; for py in $(py3versions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import silx.test; silx.test.run_tests()" 2>&1
+ ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -m unittest discover silx 2>&1
; done
Depends: python3-all, python3-silx, xauth, xvfb
@@ -26,6 +26,6 @@ Test-Command: set -efu
; for py in $(py3versions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py-dbg:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py-dbg -c "import silx.test; silx.test.run_tests()" 2>&1
+ ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py-dbg -m unittest discover silx 2>&1
; done
Depends: python3-all-dbg, python3-silx-dbg, xauth, xvfb