summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2018-03-04 11:04:01 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-03-04 11:14:27 +0100
commit35737489340e8174a7b64807d7e85de4ab7c0f56 (patch)
treeb472d8f2630982a093aecfb900ae96328c2b7baf
parent1b77b357d6951b274849868ffa865c48c4a472d0 (diff)
add the futures package for python2
-rw-r--r--debian/control1
-rw-r--r--debian/patches/0007-add-install_requires-dependencies.patch9
-rw-r--r--debian/pydist-overrides1
3 files changed, 7 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index b176a43..4a80546 100644
--- a/debian/control
+++ b/debian/control
@@ -17,6 +17,7 @@ Build-Depends: cython (>= 0.23.2),
ipython3-qtconsole,
python-all-dbg,
python-all-dev,
+ python-concurrent.futures,
python-enum34,
python-fabio,
python-fabio-dbg,
diff --git a/debian/patches/0007-add-install_requires-dependencies.patch b/debian/patches/0007-add-install_requires-dependencies.patch
index bc04415..44dfd09 100644
--- a/debian/patches/0007-add-install_requires-dependencies.patch
+++ b/debian/patches/0007-add-install_requires-dependencies.patch
@@ -4,20 +4,21 @@ Date: Thu, 17 Aug 2017 09:30:39 +0200
Subject: add install_requires dependencies
---
- setup.py | 18 +++++++++++++++++-
- 1 file changed, 17 insertions(+), 1 deletion(-)
+ setup.py | 19 ++++++++++++++++++-
+ 1 file changed, 18 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 08e4f90..da74ffd 100644
+index 08e4f90..855ca09 100644
--- a/setup.py
+++ b/setup.py
-@@ -776,7 +776,23 @@ def get_project_configuration(dry_run):
+@@ -776,7 +776,24 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy",
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # Debian added
++ 'futures;python_version<"3.2"',
+ "ipython",
+ "qtconsole",
+ 'enum34;python_version<"3.4"',
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
index a9fde6e..4a84372 100644
--- a/debian/pydist-overrides
+++ b/debian/pydist-overrides
@@ -1,2 +1,3 @@
pyqt5 python-pyqt5,python-pyqt5.qtopengl,python-pyqt5.qtsvg
enum34_python_version python-enum34
+futures_python_version python-concurrent.futures