summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2018-03-13 20:03:55 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-03-13 20:41:38 +0100
commitb352c9b517c1c2b0ed6365ab763986b8563b1b9b (patch)
tree3ccb7b155c0c48a3f673cb03e1dcb1931f448ae5
parent1e7cc72b26df13b77d07d4ebf0ff5bfdef575527 (diff)
use py3versions to get the default python3 interpreter version.debian/0.7.0+dfsg-2
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules5
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8da49b5..81c83d7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+silx (0.7.0+dfsg-2) unstable; urgency=medium
+
+ * d/rules
+ - use py3versions to get the python3 default interpreter version.
+ This makes the package backportable.
+
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Tue, 13 Mar 2018 20:04:20 +0100
+
silx (0.7.0+dfsg-1) unstable; urgency=medium
* New upstream version 0.7.0+dfsg
diff --git a/debian/rules b/debian/rules
index 9d8b103..1f3c86d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,9 @@ rwildcard=$(wildcard $1$2) $(foreach d,$(wildcard $1*),$(call rwildcard,$d/,$2))
ALL_PYX := $(call rwildcard,silx/,*.pyx)
#NOTA: No space before *
+# get the default python3 interpreter version
+PY3VER := $(shell py3versions -dv)
+
%:
dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
@@ -65,7 +68,7 @@ override_dh_installman:
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
- pybuild --build -s custom -p 3.6 --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
+ pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
dh_installdocs "doc/build/html" -p python-silx-doc
dh_sphinxdoc -O--buildsystem=pybuild
endif