summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefano Rivera <stefanor@debian.org>2023-02-03 15:38:37 -0400
committerStefano Rivera <stefanor@debian.org>2023-02-03 16:46:41 -0400
commitda81292ced89bf11129144de18c04af060fa1226 (patch)
treea98e904e3a29bd347e957b786f8c6f816bde9a1a
parent6f42f048be7f7a8dbec4519b8a6707a1f9e14056 (diff)
Patch out tests that fail on mipsel / mips64el due to a numpy bug.
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch42
-rw-r--r--debian/patches/series1
3 files changed, 49 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 0ec5d74..abfaaf0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+silx (1.1.0+dfsg-5) UNRELEASED; urgency=medium
+
+ * Patch out tests that fail on mipsel / mips64el due to a numpy bug.
+
+ -- Stefano Rivera <stefanor@debian.org> Fri, 03 Feb 2023 15:36:50 -0400
+
silx (1.1.0+dfsg-4) unstable; urgency=medium
* Team upload.
diff --git a/debian/patches/0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch b/debian/patches/0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch
new file mode 100644
index 0000000..27a396a
--- /dev/null
+++ b/debian/patches/0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch
@@ -0,0 +1,42 @@
+From: Stefano Rivera <stefanor@debian.org>
+Date: Fri, 3 Feb 2023 15:34:10 -0400
+Subject: Skip testing nanmin() on float64 arrays on mips*el
+
+This fails on mipsel and mips64el, due to a numpy bug:
+Bug-numpy: https://github.com/numpy/numpy/issues/23158
+---
+ src/silx/math/test/test_combo.py | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/src/silx/math/test/test_combo.py b/src/silx/math/test/test_combo.py
+index eed0625..bb3f4e4 100644
+--- a/src/silx/math/test/test_combo.py
++++ b/src/silx/math/test/test_combo.py
+@@ -27,6 +27,7 @@ __license__ = "MIT"
+ __date__ = "17/01/2018"
+
+
++import sys
+ import unittest
+
+ import numpy
+@@ -164,6 +165,9 @@ class TestMinMax(ParametricTestCase):
+ def test_nandata(self):
+ """Test min_max with NaN in data"""
+ for dtype in self.FLOATING_DTYPES:
++ if dtype == 'float64' and sys.implementation._multiarch in (
++ 'mips64el-linux-gnuabi64', 'mipsel-linux-gnu'):
++ continue
+ for data in self.NAN_TEST_DATA:
+ with self.subTest(dtype=dtype, data=data):
+ data = numpy.array(data, dtype=dtype)
+@@ -181,6 +185,9 @@ class TestMinMax(ParametricTestCase):
+ def test_infdata(self):
+ """Test min_max with inf."""
+ for dtype in self.FLOATING_DTYPES:
++ if dtype == 'float64' and sys.implementation._multiarch in (
++ 'mips64el-linux-gnuabi64', 'mipsel-linux-gnu'):
++ continue
+ for data in self.INF_TEST_DATA:
+ with self.subTest(dtype=dtype, data=data):
+ data = numpy.array(data, dtype=dtype)
diff --git a/debian/patches/series b/debian/patches/series
index b928d56..dccb14e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -6,3 +6,4 @@
0007-python3.10-fix.patch
0007-do-not-install-scipy_spatial-COPYING.txt.patch
0008-python3.11-fix.patch
+0009-Skip-testing-nanmin-on-float64-arrays-on-mips-el.patch