summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-08-17 09:30:39 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-08-08 14:18:01 +0200
commit6c5e137971e9de0fc65e30517cdc03fcf630561f (patch)
treed19874fb8f2528cb083c0cfb2984ed9c9b14de6d
parentf103b56edc33ca3dbc49ca3b7c7153dcaac53179 (diff)
add install_requires dependencies
Gbp-Pq: Name 0007-add-install_requires-dependencies.patch
-rw-r--r--setup.py19
1 files changed, 18 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bc7ea27..8c4dd3d 100644
--- a/setup.py
+++ b/setup.py
@@ -857,7 +857,24 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy %s" % numpy_requested_version,
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # Debian added
+ 'futures;python_version<"3.2"',
+ "ipython",
+ "qtconsole",
+ 'enum34;python_version<"3.4"',
+ "fabio",
+ "h5py",
+ "lxml",
+ "mako",
+ "matplotlib",
+ "PyOpenGL",
+ "pil",
+ "pyopencl",
+ "PyQt5",
+ "scipy",
+ "six"
+ ]
setup_requires = ["setuptools", "numpy"]