summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2018-03-04 12:58:36 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-03-04 17:34:01 +0100
commitbd4ad82e78f9e4f73476ab4fb91af6814fe1f292 (patch)
treec040fd0442e00da08f81b344d70ace9625f386ee
parent061f22c7cca0a289dc1187628c0b72ae5acdb4a6 (diff)
modified rules in order to build the modules only once.
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch22
-rw-r--r--debian/patches/0007-add-install_requires-dependencies.patch4
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules12
5 files changed, 37 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 7ab9cb0..a9d87d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,10 +5,14 @@ silx (0.7.0+dfsg-1) UNRELEASED; urgency=medium
* New upstream version 0.7.0+dfsg
* Bumped Strandards-Versions to 4.1.3 (nothing to do)
* d/patches
+ + 0003-do-not-modify-PYTHONPATH-from-setup.py.patch (added)
- 0005-slocale.h-is-removed-in-GLIBC-2.26.patch (obsolete)
- 0006-prefer-pyqt5-over-pyside.patch (obsolete)
+ * add the futures package for python2
+ * removed jessie backports code
+ * rework rules in order to reduce the build time
- -- Picca Frédéric-Emmanuel <picca@debian.org> Sun, 04 Mar 2018 10:55:59 +0100
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Sun, 04 Mar 2018 16:37:41 +0100
silx (0.6.1+dfsg-2) unstable; urgency=medium
diff --git a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
new file mode 100644
index 0000000..87c0449
--- /dev/null
+++ b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
@@ -0,0 +1,22 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?= <picca@debian.org>
+Date: Sun, 4 Mar 2018 16:36:35 +0100
+Subject: do not modify PYTHONPATH from setup.py
+
+---
+ setup.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 08e4f90..51f9be2 100644
+--- a/setup.py
++++ b/setup.py
+@@ -251,7 +251,8 @@ class BuildMan(Command):
+ path.insert(0, os.path.abspath(build.build_lib))
+
+ env = dict((str(k), str(v)) for k, v in os.environ.items())
+- env["PYTHONPATH"] = os.pathsep.join(path)
++
++ # env["PYTHONPATH"] = os.pathsep.join(path)
+ if not os.path.isdir("build/man"):
+ os.makedirs("build/man")
+ import subprocess
diff --git a/debian/patches/0007-add-install_requires-dependencies.patch b/debian/patches/0007-add-install_requires-dependencies.patch
index 44dfd09..ad127d1 100644
--- a/debian/patches/0007-add-install_requires-dependencies.patch
+++ b/debian/patches/0007-add-install_requires-dependencies.patch
@@ -8,10 +8,10 @@ Subject: add install_requires dependencies
1 file changed, 18 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 08e4f90..855ca09 100644
+index 51f9be2..d214b5a 100644
--- a/setup.py
+++ b/setup.py
-@@ -776,7 +776,24 @@ def get_project_configuration(dry_run):
+@@ -777,7 +777,24 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy",
# for the script launcher
diff --git a/debian/patches/series b/debian/patches/series
index 1339c13..40de024 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
0002-use-the-system-mathjax-privacy-breach.patch
0003-fix-unit-test.patch
+0003-do-not-modify-PYTHONPATH-from-setup.py.patch
0007-add-install_requires-dependencies.patch
diff --git a/debian/rules b/debian/rules
index 890a232..150311a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,13 +22,15 @@ override_dh_clean:
rm -f $(patsubst %.pyx,%.cpp,${ALL_PYX})
rm -f $(patsubst %.pyx,%.c,${ALL_PYX})
rm -f $(patsubst %.pyx,%.html,${ALL_PYX})
- rm -rf build/html build/man
+ rm -rf doc/build/html
+ rm -rf build/man
rm -rf *.egg-info
rm -rf $(POCL_CACHE_DIR)
override_dh_auto_build:
- python setup.py build build_man
dh_auto_build
+ # build man pages
+ dh_auto_build -- -s custom --build-args="env PYTHONPATH={build_dir} {interpreter} setup.py build_man"
override_dh_install:
dh_numpy
@@ -51,7 +53,7 @@ override_dh_install:
# https://lists.debian.org/debian-python/2017/08/msg00095.html
override_dh_auto_test:
mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
- dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -v"
+ dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
override_dh_installman:
dh_installman -p silx build/man/*.1
@@ -59,7 +61,7 @@ override_dh_installman:
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
- python setup.py build build_doc
- dh_installdocs "build/sphinx/html" -p python-silx-doc
+ dh_auto_build -- -s custom --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
+ dh_installdocs "doc/build/html" -p python-silx-doc
dh_sphinxdoc -O--buildsystem=pybuild
endif