summaryrefslogtreecommitdiff
path: root/PKG-INFO
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-08-18 14:48:52 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-08-18 14:48:52 +0200
commitf7bdc2acff3c13a6d632c28c4569690ab106eed7 (patch)
tree9d67cdb7152ee4e711379e03fe0546c7c3b97303 /PKG-INFO
Import Upstream version 0.5.0+dfsg
Diffstat (limited to 'PKG-INFO')
-rw-r--r--PKG-INFO140
1 files changed, 140 insertions, 0 deletions
diff --git a/PKG-INFO b/PKG-INFO
new file mode 100644
index 0000000..7a6c11c
--- /dev/null
+++ b/PKG-INFO
@@ -0,0 +1,140 @@
+Metadata-Version: 1.1
+Name: silx
+Version: 0.5.0
+Summary: Software library for X-Ray data analysis
+Home-page: https://github.com/silx-kit/silx
+Author: data analysis unit
+Author-email: silx@esrf.fr
+License: UNKNOWN
+Description:
+ silx toolkit
+ ============
+
+ The silx project aims at providing a collection of Python packages to support the development of data assessment, reduction and analysis applications at synchrotron radiation facilities.
+ It aims at providing reading/writing different file formats, data reduction routines and a set of Qt widgets to browse and visualize data.
+
+ The current version provides :
+
+ * reading `HDF5 <https://www.hdfgroup.org/HDF5/>`_ file format (with support of `SPEC <https://certif.com/spec.html>`_ file format)
+ * histogramming
+ * fitting
+ * 1D and 2D visualization using multiple backends (matplotlib or OpenGL)
+ * image plot widget with a set of associated tools (See `changelog file <https://github.com/silx-kit/silx/blob/master/CHANGELOG.rst>`_).
+ * Unified browser for HDF5, SPEC and image file formats supporting inspection and visualization of n-dimensional datasets.
+ * Unified viewer (silx view filename) for HDF5, SPEC and image file formats
+ * OpenGL-based widget to display 3D scalar field with isosurface and cutting plane.
+ * image alignement (sift - OpenCL implementation)
+
+ Installation
+ ------------
+
+ To install silx, run::
+
+ pip install silx
+
+ To install silx locally, run::
+
+ pip install silx --user
+
+ On Linux, to install silx with pip, you must install numpy first. Unofficial packages for different distributions are available :
+
+ - Unofficial Debian8 packages are available at http://www.silx.org/pub/debian/
+ - CentOS 7 rpm packages are provided by Max IV at the following url: http://pubrepo.maxiv.lu.se/rpm/el7/x86_64/
+ - Fedora 23 rpm packages are provided by Max IV at http://pubrepo.maxiv.lu.se/rpm/fc23/x86_64/
+ - Arch Linux (AUR) packages are also available: https://aur.archlinux.org/packages/python-silx
+
+ On Windows, pre-compiled binaries (aka Python wheels) are available for Python 2.7, 3.5 and 3.6.
+
+ On Mac OS X, pre-compiled binaries (aka Python wheels) are available for Python 2.7.
+
+ The latest development version can be obtained from the git repository::
+
+ git clone https://github.com/silx-kit/silx.git
+ cd silx
+ pip install . [--user]
+
+ Dependencies
+ ------------
+
+ * `Python <https://www.python.org/>`_ 2.7, 3.4 or above.
+ * `numpy <http://www.numpy.org>`_
+
+ The GUI widgets of the silx package depend on the following extra packages:
+
+ * A Qt binding: `PyQt5, PyQt4 <https://riverbankcomputing.com/software/pyqt/intro>`_ (using API version 2) or `PySide <https://pypi.python.org/pypi/PySide/>`_
+ * `matplotlib <http://matplotlib.org/>`_ for the silx.gui.plot package
+ * `PyOpenGL <http://pyopengl.sourceforge.net/>`_ for the silx.gui.plot3d package
+
+ Most modules and functions dealing with `HDF5 <https://www.hdfgroup.org/HDF5/>`_ input/output depend on the following extra package:
+ * `h5py <http://www.h5py.org/>`_
+
+ * `ipython <https://ipython.org/>`_ and `qtconsole <https://pypi.python.org/pypi/qtconsole>`_ is required by silx.gui.console.py
+
+ Supported platforms: Linux, Windows, Mac OS X.
+
+ Documentation
+ -------------
+
+ Documentation of releases is available at https://pythonhosted.org/silx/
+
+ Latest documentation (nightly build) is available at http://www.silx.org/doc/silx/
+
+ To build the documentation from the source (requires `Sphinx <http://www.sphinx-doc.org>`_), run::
+
+ python setup.py build build_doc
+
+ Testing
+ -------
+
+ - Travis CI status: |Travis Status|
+ - Appveyor CI status: |Appveyor Status|
+
+ To run the tests from the python interpreter, run:
+
+ >>> import silx.test
+ >>> silx.test.run_tests()
+
+ To run the tests, from the source directory, run::
+
+ python run_tests.py
+
+ Examples
+ --------
+
+ Some examples are available in the source code repository. For example::
+
+ python examples/{exampleName.py}
+
+
+ License
+ -------
+
+ The source code of silx is licensed under the MIT and LGPL licenses.
+ See the `copyright file <https://github.com/silx-kit/silx/blob/master/copyright>`_ for details.
+
+ .. |Travis Status| image:: https://travis-ci.org/silx-kit/silx.svg?branch=master
+ :target: https://travis-ci.org/silx-kit/silx
+ .. |Appveyor Status| image:: https://ci.appveyor.com/api/projects/status/qgox9ei0wxwfagrb/branch/master?svg=true
+ :target: https://ci.appveyor.com/project/ESRF/silx
+
+Platform: UNKNOWN
+Classifier: Development Status :: 4 - Beta
+Classifier: Environment :: Console
+Classifier: Environment :: MacOS X
+Classifier: Environment :: Win32 (MS Windows)
+Classifier: Environment :: X11 Applications :: Qt
+Classifier: Intended Audience :: Education
+Classifier: Intended Audience :: Science/Research
+Classifier: License :: OSI Approved :: MIT License
+Classifier: License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)
+Classifier: Natural Language :: English
+Classifier: Operating System :: MacOS
+Classifier: Operating System :: Microsoft :: Windows
+Classifier: Operating System :: POSIX
+Classifier: Programming Language :: Cython
+Classifier: Programming Language :: Python :: 2.7
+Classifier: Programming Language :: Python :: 3.4
+Classifier: Programming Language :: Python :: 3.5
+Classifier: Programming Language :: Python :: Implementation :: CPython
+Classifier: Topic :: Scientific/Engineering :: Physics
+Classifier: Topic :: Software Development :: Libraries :: Python Modules