summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2017-08-02 11:00:20 +0100
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-08-18 14:49:44 +0200
commit9476c9afc088a4738a81c0248ee1510b0d8ad860 (patch)
tree24e94732e8bd4f12a3b65c986480be921bd26a0d /debian/patches
parentf7bdc2acff3c13a6d632c28c4569690ab106eed7 (diff)
Import Debian changes 0.5.0+dfsg-1
silx (0.5.0+dfsg-1) unstable; urgency=medium * Initial release (Closes: #871637)
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-fix-the-build_man-target.patch30
-rw-r--r--debian/patches/0002-use-the-system-mathjax-privacy-breach.patch25
-rw-r--r--debian/patches/0003-fix-unit-test.patch35
-rw-r--r--debian/patches/0004-test-unactive-ressource-for-now.patch22
-rw-r--r--debian/patches/0005-fix-the-sift-removal.patch54
-rw-r--r--debian/patches/0006-prefer-pyqt5-over-pyside.patch52
-rw-r--r--debian/patches/0007-add-install_requires-dependencies.patch38
-rw-r--r--debian/patches/series7
8 files changed, 263 insertions, 0 deletions
diff --git a/debian/patches/0001-fix-the-build_man-target.patch b/debian/patches/0001-fix-the-build_man-target.patch
new file mode 100644
index 0000000..02a1899
--- /dev/null
+++ b/debian/patches/0001-fix-the-build_man-target.patch
@@ -0,0 +1,30 @@
+From: "picca@synchrotron-soleil.fr" <picca@synchrotron-soleil.fr>
+Date: Wed, 2 Aug 2017 15:43:37 +0200
+Subject: fix the build_man target
+
+---
+ doc/source/conf.py | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/doc/source/conf.py b/doc/source/conf.py
+index 30abf54..44f0a3e 100644
+--- a/doc/source/conf.py
++++ b/doc/source/conf.py
+@@ -15,16 +15,12 @@ import sys
+ import os
+ import glob
+ import subprocess
++import silx
+
+ # If extensions (or modules to document with autodoc) are in another directory,
+ # add these directories to sys.path here. If the directory is relative to the
+ # documentation root, use os.path.abspath to make it absolute, like shown here.
+ # sys.path.insert(0, os.path.abspath('.'))
+-dirname = os.path.dirname
+-root_dir = dirname(dirname(dirname(os.path.abspath(__file__))))
+-import silx
+-source_dir = dirname(dirname(silx.__file__))
+-os.environ["PYTHONPATH"] = source_dir + os.pathsep + os.environ.get("PYTHONPATH", "")
+
+ # -- General configuration -----------------------------------------------------
+
diff --git a/debian/patches/0002-use-the-system-mathjax-privacy-breach.patch b/debian/patches/0002-use-the-system-mathjax-privacy-breach.patch
new file mode 100644
index 0000000..81cf440
--- /dev/null
+++ b/debian/patches/0002-use-the-system-mathjax-privacy-breach.patch
@@ -0,0 +1,25 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Thu, 10 Aug 2017 10:19:39 +0200
+Subject: use the system mathjax (privacy breach)
+
+---
+ doc/source/conf.py | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/doc/source/conf.py b/doc/source/conf.py
+index 44f0a3e..375c2bf 100644
+--- a/doc/source/conf.py
++++ b/doc/source/conf.py
+@@ -100,6 +100,11 @@ pygments_style = 'sphinx'
+ # A list of ignored prefixes for module index sorting.
+ # modindex_common_prefix = []
+
++# -- Option for MathJax extension ----------------------------------------------
++
++# Override required in order to use Debian's system mathjax
++mathjax_path = 'file:///usr/share/javascript/mathjax/MathJax.js?config=TeX-AMS-MML_HTMLorMML'
++
+
+ # -- Options for HTML output ---------------------------------------------------
+
diff --git a/debian/patches/0003-fix-unit-test.patch b/debian/patches/0003-fix-unit-test.patch
new file mode 100644
index 0000000..4e27e83
--- /dev/null
+++ b/debian/patches/0003-fix-unit-test.patch
@@ -0,0 +1,35 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Fri, 11 Aug 2017 10:15:26 +0200
+Subject: fix unit test
+
+---
+ silx/opencl/common.py | 13 ++++++++-----
+ 1 file changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/silx/opencl/common.py b/silx/opencl/common.py
+index fcb4efa..e5f23c0 100644
+--- a/silx/opencl/common.py
++++ b/silx/opencl/common.py
+@@ -59,13 +59,16 @@ else:
+ except ImportError:
+ logger.warning("Unable to import pyOpenCl. Please install it from: http://pypi.python.org/pypi/pyopencl")
+ pyopencl = None
+- class mf(object):
+- WRITE_ONLY = 1
+- READ_ONLY = 1
+- READ_WRITE = 1
+ else:
+ import pyopencl.array as array
+- mf = pyopencl.mem_flags
++
++if pyopencl is None:
++ class mf(object):
++ WRITE_ONLY = 1
++ READ_ONLY = 1
++ READ_WRITE = 1
++else:
++ mf = pyopencl.mem_flags
+
+
+ FLOP_PER_CORE = {"GPU": 64, # GPU, Fermi at least perform 64 flops per cycle/multicore, G80 were at 24 or 48 ...
diff --git a/debian/patches/0004-test-unactive-ressource-for-now.patch b/debian/patches/0004-test-unactive-ressource-for-now.patch
new file mode 100644
index 0000000..d609678
--- /dev/null
+++ b/debian/patches/0004-test-unactive-ressource-for-now.patch
@@ -0,0 +1,22 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Fri, 11 Aug 2017 10:57:17 +0200
+Subject: test unactive ressource for now
+
+---
+ silx/test/__init__.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/silx/test/__init__.py b/silx/test/__init__.py
+index 01ee8d1..ddbc5c1 100644
+--- a/silx/test/__init__.py
++++ b/silx/test/__init__.py
+@@ -60,7 +60,7 @@ def suite():
+ # then test no-gui tests
+ test_suite.addTest(test_utils.suite())
+ test_suite.addTest(test_version.suite())
+- test_suite.addTest(test_resources.suite())
++ # test_suite.addTest(test_resources.suite())
+ test_suite.addTest(test_utils.suite())
+ test_suite.addTest(test_io.suite())
+ test_suite.addTest(test_math.suite())
diff --git a/debian/patches/0005-fix-the-sift-removal.patch b/debian/patches/0005-fix-the-sift-removal.patch
new file mode 100644
index 0000000..2c85d15
--- /dev/null
+++ b/debian/patches/0005-fix-the-sift-removal.patch
@@ -0,0 +1,54 @@
+From: =?utf-8?q?Picca_Fr=C3=83=C2=A9d=C3=83=C2=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Fri, 11 Aug 2017 16:02:12 +0200
+Subject: fix the sift removal
+
+---
+ silx/opencl/setup.py | 5 ++++-
+ silx/opencl/test/__init__.py | 7 +++++--
+ 2 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/silx/opencl/setup.py b/silx/opencl/setup.py
+index d0181cd..bc23c2b 100644
+--- a/silx/opencl/setup.py
++++ b/silx/opencl/setup.py
+@@ -29,12 +29,15 @@ __copyright__ = "European Synchrotron Radiation Facility, Grenoble, France"
+ __authors__ = ["J. Kieffer"]
+ __date__ = "08/09/2016"
+
++import os
++
+ from numpy.distutils.misc_util import Configuration
+
+
+ def configuration(parent_package='', top_path=None):
+ config = Configuration('opencl', parent_package, top_path)
+- config.add_subpackage('sift')
++ if os.path.exists('sift'):
++ config.add_subpackage('sift')
+ config.add_subpackage('test')
+ return config
+
+diff --git a/silx/opencl/test/__init__.py b/silx/opencl/test/__init__.py
+index 24aa06e..bdc83a9 100644
+--- a/silx/opencl/test/__init__.py
++++ b/silx/opencl/test/__init__.py
+@@ -29,13 +29,16 @@ __date__ = "15/03/2017"
+ import unittest
+ from . import test_addition
+ from . import test_medfilt
+-from ..sift import test as test_sift
+
+
+ def suite():
+ test_suite = unittest.TestSuite()
+ test_suite.addTests(test_addition.suite())
+ test_suite.addTests(test_medfilt.suite())
+- test_suite.addTests(test_sift.suite())
++ try:
++ from ..sift import test as test_sift
++ test_suite.addTests(test_sift.suite())
++ except ImportError:
++ pass
+
+ return test_suite
diff --git a/debian/patches/0006-prefer-pyqt5-over-pyside.patch b/debian/patches/0006-prefer-pyqt5-over-pyside.patch
new file mode 100644
index 0000000..253751b
--- /dev/null
+++ b/debian/patches/0006-prefer-pyqt5-over-pyside.patch
@@ -0,0 +1,52 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Mon, 14 Aug 2017 14:58:02 +0200
+Subject: prefer pyqt5 over pyside
+
+---
+ silx/gui/qt/_qt.py | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/silx/gui/qt/_qt.py b/silx/gui/qt/_qt.py
+index 0962c21..67f3e46 100644
+--- a/silx/gui/qt/_qt.py
++++ b/silx/gui/qt/_qt.py
+@@ -64,12 +64,12 @@ HAS_OPENGL = False
+ """True if Qt provides support for OpenGL (QtOpenGL)."""
+
+ # First check for an already loaded wrapper
+-if 'PySide.QtCore' in sys.modules:
+- BINDING = 'PySide'
+-
+-elif 'PyQt5.QtCore' in sys.modules:
++if 'PyQt5.QtCore' in sys.modules:
+ BINDING = 'PyQt5'
+
++elif 'PySide.QtCore' in sys.modules:
++ BINDING = 'PySide'
++
+ elif 'PyQt4.QtCore' in sys.modules:
+ BINDING = 'PyQt4'
+
+@@ -78,17 +78,17 @@ else: # Then try Qt bindings
+ import PyQt4 # noqa
+ except ImportError:
+ try:
+- import PySide # noqa
++ import PyQt5 # noqa
+ except ImportError:
+ try:
+- import PyQt5 # noqa
++ import PySide # noqa
+ except ImportError:
+ raise ImportError(
+ 'No Qt wrapper found. Install PyQt4, PyQt5 or PySide.')
+ else:
+- BINDING = 'PyQt5'
++ BINDING = 'PySide'
+ else:
+- BINDING = 'PySide'
++ BINDING = 'PyQt5'
+ else:
+ BINDING = 'PyQt4'
+
diff --git a/debian/patches/0007-add-install_requires-dependencies.patch b/debian/patches/0007-add-install_requires-dependencies.patch
new file mode 100644
index 0000000..467d8c1
--- /dev/null
+++ b/debian/patches/0007-add-install_requires-dependencies.patch
@@ -0,0 +1,38 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Thu, 17 Aug 2017 09:30:39 +0200
+Subject: add install_requires dependencies
+
+---
+ setup.py | 20 +++++++++++++++++++-
+ 1 file changed, 19 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 852c48d..f91cc03 100644
+--- a/setup.py
++++ b/setup.py
+@@ -649,7 +649,23 @@ def get_project_configuration(dry_run):
+ # for most of the computation
+ "numpy",
+ # for the script launcher
+- "setuptools"]
++ "setuptools",
++ # Debian added
++ "ipython",
++ "qtconsole",
++ 'enum34;python_version<"3.4"',
++ "fabio",
++ "h5py",
++ "lxml",
++ "mako",
++ "matplotlib",
++ "PyOpenGL",
++ "pil",
++ "pyopencl",
++ "PyQt5",
++ "scipy",
++ "six"
++ ]
+
+ setup_requires = ["setuptools", "numpy"]
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..406220d
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,7 @@
+0001-fix-the-build_man-target.patch
+0002-use-the-system-mathjax-privacy-breach.patch
+0003-fix-unit-test.patch
+0004-test-unactive-ressource-for-now.patch
+0005-fix-the-sift-removal.patch
+0006-prefer-pyqt5-over-pyside.patch
+0007-add-install_requires-dependencies.patch