summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-07-31 16:26:56 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-07-31 16:30:37 +0200
commitb2fc246b2a35596c8e3de092f9a07e9483d93d38 (patch)
tree88c537fc5114f67dec69161d279a53837586cab8 /debian/patches
parent25b576b765ecb4ef6aeb060a21ccd01c85328d46 (diff)
refresh patch series
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch4
-rw-r--r--debian/patches/0007-add-install_requires-dependencies.patch6
2 files changed, 5 insertions, 5 deletions
diff --git a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
index 87c0449..9a82a2b 100644
--- a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
+++ b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
@@ -7,10 +7,10 @@ Subject: do not modify PYTHONPATH from setup.py
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 08e4f90..51f9be2 100644
+index 69a6dca..bc7ea27 100644
--- a/setup.py
+++ b/setup.py
-@@ -251,7 +251,8 @@ class BuildMan(Command):
+@@ -257,7 +257,8 @@ class BuildMan(Command):
path.insert(0, os.path.abspath(build.build_lib))
env = dict((str(k), str(v)) for k, v in os.environ.items())
diff --git a/debian/patches/0007-add-install_requires-dependencies.patch b/debian/patches/0007-add-install_requires-dependencies.patch
index ad127d1..940ac56 100644
--- a/debian/patches/0007-add-install_requires-dependencies.patch
+++ b/debian/patches/0007-add-install_requires-dependencies.patch
@@ -8,12 +8,12 @@ Subject: add install_requires dependencies
1 file changed, 18 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 51f9be2..d214b5a 100644
+index bc7ea27..8c4dd3d 100644
--- a/setup.py
+++ b/setup.py
-@@ -777,7 +777,24 @@ def get_project_configuration(dry_run):
+@@ -857,7 +857,24 @@ def get_project_configuration(dry_run):
# for most of the computation
- "numpy",
+ "numpy %s" % numpy_requested_version,
# for the script launcher
- "setuptools"]
+ "setuptools",