summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2019-10-19 10:25:46 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2019-10-19 13:19:26 +0200
commitd21da9990a9bf890d578fe1ab738685c0ae795c5 (patch)
tree30e676a2b23d2b62f14060df4bbfd66a2cd494b6 /debian/rules
parent9a7abf97d769bef6f173f1b8da0332b5b938493f (diff)
switched to compat level 12
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 1 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 2066404..d086f63 100755
--- a/debian/rules
+++ b/debian/rules
@@ -65,8 +65,6 @@ override_dh_python3:
# SILX_TEST_LOW_MEM=True to disable tests taking large amount of memory
# GPU=False to disable the use of a GPU with OpenCL test
# WITH_GL_TEST=False to disable tests using OpenGL
-# UNACTIVATED UNTIL dh_python from UNSTABLE IS FIXED
-# https://lists.debian.org/debian-python/2017/08/msg00095.html
override_dh_auto_test:
mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False WITH_QT_TEST=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
@@ -79,6 +77,6 @@ ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
#mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
mkdir -p -m 700 $(XDG_RUNTIME_DIR)
pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} -m sphinx -N -bhtml source build/html"
- dh_installdocs "doc/build/html" -p python-silx-doc
+ dh_installdocs "doc/build/html" -p python-silx-doc --doc-main-package=python3-silx
dh_sphinxdoc -O--buildsystem=pybuild
endif